{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2025-5683 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2025-5683 is a medium-severity denial of service vulnerability in Qt Qt, published on 5 Jun 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2025-5683 and fix it if it is affected.\n\nWhat it is: CVE-2025-5683 is a medium-severity denial of service vulnerability in Qt Qt, published on 5 Jun 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2025-5683 in the wild and no public exploit code.\n\nAffected product: Qt Qt. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-5683/ (Markdown: https://insights.sbomify.com/CVE-2025-5683/index.md)","id":"CVE-2025-5683","markdown":"https://insights.sbomify.com/CVE-2025-5683/index.md","name":"CVE-2025-5683","record":{"aliases":["DEBIAN-CVE-2025-5683","GHSA-5mw2-w8pc-m6p6","MGASA-2025-0208","OESA-2025-1708","OESA-2025-1709","OESA-2025-1794","OESA-2025-2492","OESA-2025-2493","OESA-2025-2494","OESA-2025-2495","OESA-2025-2496","OESA-2025-2581","UBUNTU-CVE-2025-5683"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Qt image library","requires_auth":"none","summary":"Attackers can cause a crash in applications using Qt by loading a specially crafted ICNS image file, requiring an upgrade to patched versions.","user_interaction":"required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"TQtC","cpe":[{"product":"qt","vendor":"qt"}],"cvss":{"score":5.1,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:A/VC:N/VI:N/VA:L/SC:N/SI:N/SA:L","version":"4.0"},"cwes":[{"id":"CWE-770","name":"Allocation of Resources Without Limits or Throttling"}],"description":"When loading a specifically crafted ICNS format image file in QImage then it will trigger a crash. \n\nThis issue affects Qt from versions 6.3.0 through 6.5.9, from 6.6.0 through 6.8.4, 6.9.0. This is fixed in 6.5.10, 6.8.5 and 6.9.1.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Denial of service in Qt","id":"CVE-2025-5683","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":"qt:qt","products":["qt:qt"],"type":"denial_of_service","year":"2025"},"n_packages":0,"n_references":2,"next":{"headline":"MetForm \u003c= 4.0.1 - Authenticated(Contributor+) Stored Cross-Site Scripting via `mf-template` DOM Element","id":"CVE-2025-5684"},"packages":[],"prev":{"headline":"Klaro Cookie \u0026 Consent Management - Moderately critical - Cross-site Scripting - SA-CONTRIB-2025-080","id":"CVE-2025-5682"},"products":["Qt"],"published":"2025-06-05","related":[{"cvss_score":9.8,"headline":"Use after free in n/a","id":"CVE-2020-12267","kev_date_added":null,"published":"2020-04-27"},{"cvss_score":9.8,"headline":"Command injection in Qt for Android","id":"CVE-2017-10904","kev_date_added":null,"published":"2017-12-15"},{"cvss_score":9.3,"headline":"Memory corruption in n/a","id":"CVE-2011-3194","kev_date_added":null,"published":"2012-06-16"},{"cvss_score":8.8,"headline":"Integer overflow in Qt","id":"CVE-2022-40983","kev_date_added":null,"published":"2023-01-12"},{"cvss_score":8.8,"headline":"Memory corruption in Qt","id":"CVE-2022-43591","kev_date_added":null,"published":"2023-01-12"},{"cvss_score":8.6,"headline":"Race condition in n/a","id":"CVE-2024-39936","kev_date_added":null,"published":"2024-07-04"},{"cvss_score":8.6,"headline":"Denial of service in n/a","id":"CVE-2018-21035","kev_date_added":null,"published":"2020-02-28"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-07-29","vendors":["Qt"]},"summary":"Attackers can cause a crash in applications using Qt by loading a specially crafted ICNS image file, requiring an upgrade to patched versions.","url":"https://insights.sbomify.com/CVE-2025-5683/"}