# CVE-2025-5683: Denial of service in Qt

> Attackers can cause a crash in applications using Qt by loading a specially crafted ICNS image file, requiring an upgrade to patched versions.

- **Severity:** Medium 5.1 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:A/VC:N/VI:N/VA:L/SC:N/SI:N/SA:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 5 Jun 2025
- **Updated:** 29 Jul 2026
- **Also known as:** DEBIAN-CVE-2025-5683, GHSA-5mw2-w8pc-m6p6, MGASA-2025-0208, OESA-2025-1708, OESA-2025-1709, OESA-2025-1794, OESA-2025-2492, OESA-2025-2493, OESA-2025-2494, OESA-2025-2495, OESA-2025-2496, OESA-2025-2581, UBUNTU-CVE-2025-5683

## What is CVE-2025-5683?

CVE-2025-5683 is a medium-severity denial of service vulnerability in Qt Qt, published on 5 Jun 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

When loading a specifically crafted ICNS format image file in QImage then it will trigger a crash. 

This issue affects Qt from versions 6.3.0 through 6.5.9, from 6.6.0 through 6.8.4, 6.9.0. This is fixed in 6.5.10, 6.8.5 and 6.9.1.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling)

## Which versions are affected by CVE-2025-5683?

It affects 1 product.


Products: Qt Qt.

## How do I fix CVE-2025-5683?

Upgrade to a fixed version.

## Is CVE-2025-5683 being exploited?

There is no known exploitation of CVE-2025-5683 in the wild and no public exploit code.

## Other vulnerabilities in Qt Qt

- [CVE-2020-12267](https://insights.sbomify.com/CVE-2020-12267/): Use after free in n/a (critical 9.8)
- [CVE-2017-10904](https://insights.sbomify.com/CVE-2017-10904/): Command injection in Qt for Android (critical 9.8)
- [CVE-2011-3194](https://insights.sbomify.com/CVE-2011-3194/): Memory corruption in n/a (critical 9.3)
- [CVE-2022-40983](https://insights.sbomify.com/CVE-2022-40983/): Integer overflow in Qt (high 8.8)
- [CVE-2022-43591](https://insights.sbomify.com/CVE-2022-43591/): Memory corruption in Qt (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-5683 and fix it if it is affected.

What it is: CVE-2025-5683 is a medium-severity denial of service vulnerability in Qt Qt, published on 5 Jun 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2025-5683 in the wild and no public exploit code.

Affected product: Qt Qt. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-5683/ (Markdown: https://insights.sbomify.com/CVE-2025-5683/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-5683
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-5683
- OSV: https://osv.dev/vulnerability/CVE-2025-5683

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-5683/
Summaries are generated and may contain mistakes; the official description above is the record.
