CVE-2025-5687 Local privilege escalation vulnerability in Mozilla VPN clients for macOS v2.27.0 and below.

High 7.8 Published Updated

A local privilege escalation flaw in Mozilla VPN for macOS allows attackers to gain root access from a normal user account.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Local or same network only
Victim action needed
Not needed
Fix
None listed

What is CVE-2025-5687?

CVE-2025-5687 is a high-severity vulnerability in Mozilla VPN 2.28.0, published on 11 Jun 2025. It can only be exploited from the same machine or local network, with no action from the victim.

Official description

A vulnerability in Mozilla VPN on macOS allows privilege escalation from a normal user to root. *This bug only affects Mozilla VPN on macOS. Other operating systems are unaffected.*. This vulnerability was fixed in Mozilla VPN 2.28.0 (macOS).

Weakness: CWE-269

Which versions are affected by CVE-2025-5687?

It affects 1 product.

Products include Mozilla Vpn.

How do I fix CVE-2025-5687?

No fix has been published for CVE-2025-5687 yet. Limit exposure of the affected software until one is available.

Is CVE-2025-5687 being exploited?

There is no known exploitation of CVE-2025-5687 in the wild and no public exploit code.

Sources

Also known as GHSA-h4m7-pg92-x2q8.

Is CVE-2025-5687 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free