# CVE-2025-5687: Local privilege escalation vulnerability in Mozilla VPN clients for macOS v2.27.0 and below.

> A local privilege escalation flaw in Mozilla VPN for macOS allows attackers to gain root access from a normal user account.

- **Severity:** High 7.8 (`CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 11 Jun 2025
- **Updated:** 13 Apr 2026
- **Also known as:** GHSA-h4m7-pg92-x2q8

## What is CVE-2025-5687?

CVE-2025-5687 is a high-severity vulnerability in Mozilla VPN 2.28.0, published on 11 Jun 2025. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

A vulnerability in Mozilla VPN on macOS allows privilege escalation from a normal user to root.
*This bug only affects Mozilla VPN on macOS. Other operating systems are unaffected.*. This vulnerability was fixed in Mozilla VPN 2.28.0 (macOS).

Weakness: CWE-269 (Improper Privilege Management)

## Which versions are affected by CVE-2025-5687?

It affects 1 product.


Products: Mozilla Vpn.

## How do I fix CVE-2025-5687?

No fix has been published for CVE-2025-5687 yet. Limit exposure of the affected software until one is available.

## Is CVE-2025-5687 being exploited?

There is no known exploitation of CVE-2025-5687 in the wild and no public exploit code.

## Other vulnerabilities in Mozilla VPN 2.28.0

- [CVE-2022-0517](https://insights.sbomify.com/CVE-2022-0517/): Code injection in Mozilla VPN (high 7.8)
- [CVE-2020-15679](https://insights.sbomify.com/CVE-2020-15679/): Auth bypass in Mozilla VPN Android 1.1.0 (high 7.6)
- [CVE-2023-4104](https://insights.sbomify.com/CVE-2023-4104/): Missing authorization in Mozilla VPN 2.16.1 (medium 5.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-5687 and fix it if it is affected.

What it is: CVE-2025-5687 is a high-severity vulnerability in Mozilla VPN 2.28.0, published on 11 Jun 2025. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-5687 in the wild and no public exploit code.

Affected product: Mozilla VPN 2.28.0. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-5687/ (Markdown: https://insights.sbomify.com/CVE-2025-5687/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-5687
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-5687
- OSV: https://osv.dev/vulnerability/CVE-2025-5687

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-5687/
Summaries are generated and may contain mistakes; the official description above is the record.
