{"answers":{"affected":"3 open source packages ship an affected version, including github.com/ubuntu/authd. It affects 1 product.","exploited":"There is no known exploitation of CVE-2025-5689 in the wild and no public exploit code.","fix":"Upgrade github.com/ubuntu/authd to 0.5.4 or later.","what":"CVE-2025-5689 is a high-severity vulnerability in Canonical authd, published on 16 Jun 2025. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-5689 and fix it if it is affected.\n\nWhat it is: CVE-2025-5689 is a high-severity vulnerability in Canonical authd, published on 16 Jun 2025. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2025-5689 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- github.com/ubuntu/authd (Go): affected all versions; fixed in 0.5.4\n- github.com/ubuntu/authd (Go): affected all versions; fixed in 0.5.4\n- github.com/ubuntu/authd (Go): affected all versions; fixed in 0.5.4\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-5689/ (Markdown: https://insights.sbomify.com/CVE-2025-5689/index.md)","id":"CVE-2025-5689","markdown":"https://insights.sbomify.com/CVE-2025-5689/index.md","name":"CVE-2025-5689","record":{"aliases":["GHSA-g8qw-mgjx-rwjr","GO-2025-3762"],"analysis":{"component_type":"server_software","fix_type":"patch","impacts":["privilege_escalation"],"network_reachable":"yes","non_default_config":false,"product_category":"Canonical authd","requires_auth":"low_privilege","summary":"First-time SSH logins via authd incorrectly assign root group permissions, allowing unauthorized privilege escalation.","user_interaction":"not_required","vuln_class":"privilege_escalation"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"canonical","cpe":[{"product":"authd","vendor":"canonical"}],"cvss":{"score":8.5,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-269","name":"Improper Privilege Management"}],"description":"A flaw was found in the temporary user record that authd uses in the pre-auth NSS. As a result, a user login for the first time will be considered to be part of the root group in the context of that SSH session.","ecosystems":["Go"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Improper Permission Management in SSH Session Handling","id":"CVE-2025-5689","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Go","product":null,"products":[],"type":"privilege_escalation","year":"2025"},"n_packages":3,"n_references":1,"next":{"headline":"Cursor allows PostgreSQL Anonymizer masked user to gain unauthorized access to authentic data","id":"CVE-2025-5690"},"packages":[{"ecosystem":"Go","fixed":["0.5.4"],"introduced":["0"],"last_affected":[],"package":"github.com/ubuntu/authd","purl":null,"source":"GHSA-g8qw-mgjx-rwjr"},{"ecosystem":"Go","fixed":["0.5.4"],"introduced":["0"],"last_affected":[],"package":"github.com/ubuntu/authd","purl":"pkg:golang/github.com/ubuntu/authd","source":"GHSA-g8qw-mgjx-rwjr"},{"ecosystem":"Go","fixed":["0.5.4"],"introduced":["0"],"last_affected":[],"package":"github.com/ubuntu/authd","purl":"pkg:golang/github.com/ubuntu/authd","source":"GO-2025-3762"}],"prev":{"headline":"Out of Bounds Write in FreeRTOS-Plus-TCP","id":"CVE-2025-5688"},"products":["authd"],"published":"2025-06-16","related":[{"cvss_score":8.8,"headline":"PAM module may allow accessing with the credentials of another user","id":"CVE-2024-9313","kev_date_added":null,"published":"2024-10-03"},{"cvss_score":7.5,"headline":"Authd allows attacker-controlled usernames to yield controllable UIDs","id":"CVE-2024-9312","kev_date_added":null,"published":"2024-10-10"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"Go Vulnerability Database","prefix":"GO"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-06-17","vendors":["Canonical"]},"summary":"First-time SSH logins via authd incorrectly assign root group permissions, allowing unauthorized privilege escalation.","url":"https://insights.sbomify.com/CVE-2025-5689/"}