# CVE-2025-5689: Improper Permission Management in SSH Session Handling

> First-time SSH logins via authd incorrectly assign root group permissions, allowing unauthorized privilege escalation.

- **Severity:** High 8.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 16 Jun 2025
- **Updated:** 17 Jun 2025
- **Also known as:** GHSA-g8qw-mgjx-rwjr, GO-2025-3762

## What is CVE-2025-5689?

CVE-2025-5689 is a high-severity vulnerability in Canonical authd, published on 16 Jun 2025. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

A flaw was found in the temporary user record that authd uses in the pre-auth NSS. As a result, a user login for the first time will be considered to be part of the root group in the context of that SSH session.

Weakness: CWE-269 (Improper Privilege Management)

## Which versions are affected by CVE-2025-5689?

3 open source packages ship an affected version, including github.com/ubuntu/authd. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/ubuntu/authd` | Go | All versions | 0.5.4 |
| `github.com/ubuntu/authd` | Go | All versions | 0.5.4 |
| `github.com/ubuntu/authd` | Go | All versions | 0.5.4 |

Products: Canonical Authd.

## How do I fix CVE-2025-5689?

Upgrade github.com/ubuntu/authd to 0.5.4 or later.

## Is CVE-2025-5689 being exploited?

There is no known exploitation of CVE-2025-5689 in the wild and no public exploit code.

## Other vulnerabilities in Canonical authd

- [CVE-2024-9313](https://insights.sbomify.com/CVE-2024-9313/): PAM module may allow accessing with the credentials of another user (high 8.8)
- [CVE-2024-9312](https://insights.sbomify.com/CVE-2024-9312/): Authd allows attacker-controlled usernames to yield controllable UIDs (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-5689 and fix it if it is affected.

What it is: CVE-2025-5689 is a high-severity vulnerability in Canonical authd, published on 16 Jun 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-5689 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/ubuntu/authd (Go): affected all versions; fixed in 0.5.4
- github.com/ubuntu/authd (Go): affected all versions; fixed in 0.5.4
- github.com/ubuntu/authd (Go): affected all versions; fixed in 0.5.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-5689/ (Markdown: https://insights.sbomify.com/CVE-2025-5689/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-5689
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-5689
- OSV: https://osv.dev/vulnerability/CVE-2025-5689

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-5689/
Summaries are generated and may contain mistakes; the official description above is the record.
