CVE-2025-5695 Teledyne FLIR AX8 Backend subscriptions.php subscribe_to_alarm command injection

Medium 5.1 Published Updated

Remote attackers can execute arbitrary commands via the subscribe_to_alarm function in the Teledyne FLIR AX8 backend.

Exploited in the wild
Not known
Login needed
An administrator
Attackable
Over the internet
Victim action needed
Not needed
Fix
None listed

What is CVE-2025-5695?

CVE-2025-5695 is a medium-severity command injection vulnerability in Teledyne FLIR AX8, published on 5 Jun 2025. An attacker needs administrator access to exploit it, with no action from the victim.

Official description

A vulnerability has been found in Teledyne FLIR AX8 up to 1.46.16. This impacts the function subscribe_to_spot/subscribe_to_delta/subscribe_to_alarm of the file /usr/www/application/models/subscriptions.php of the component Backend. Such manipulation leads to command injection. It is possible to launch the attack remotely. The exploit has been disclosed to the public and may be used. Upgrading to version 1.49.16 will fix this issue. It is suggested to upgrade the affected component. The vendor points out: "FLIR AX8 internal web site has been refactored to be able to handle the reported vulnerabilities."

Weakness: CWE-77, CWE-74

Which versions are affected by CVE-2025-5695?

It affects 1 product.

Products include Flir Flir Ax8 Firmware.

How do I fix CVE-2025-5695?

No fix has been published for CVE-2025-5695 yet. Limit exposure of the affected software until one is available.

Upgrade, and pass arguments to programs as a list instead of through a shell. More about Command injection.

Is CVE-2025-5695 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-5695 exists.

Sources

Also known as GHSA-wxmp-jjxp-g7gp.

Is CVE-2025-5695 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free