CVE-2025-57106 Memory corruption in n/a

High 7.5 Published Updated

A buffer overflow in the VTK library allows attackers to execute arbitrary code or cause denial of service via malicious GLTF files.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2025-57106?

CVE-2025-57106 is a high-severity memory corruption vulnerability in n/a, published on 31 Oct 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Kitware VTK (Visualization Toolkit) up to 9.5.0 is vulnerable to Buffer Overflow in vtkGLTFDocumentLoader. The vulnerability occurs in the BufferDataExtractionWorker template function when processing GLTF accessor data.

Weakness: CWE-122

Which versions are affected by CVE-2025-57106?

1 open source package ship an affected version, including vtk. It affects 1 product.

PackageAffectedFixed in
vtk PyPIAll versions9.5.1

Products include Vtk Vtk.

How do I fix CVE-2025-57106?

Upgrade vtk to 9.5.1 or later.

Upgrade to the fixed version. Memory-safe languages, compiler hardening and fuzzing prevent most new cases. More about Memory corruption.

Is CVE-2025-57106 being exploited?

There is no known exploitation of CVE-2025-57106 in the wild and no public exploit code.

Sources

Also known as DEBIAN-CVE-2025-57106, GHSA-5pfc-43r5-qrmg, PYSEC-2025-224, UBUNTU-CVE-2025-57106.

Is CVE-2025-57106 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free