{"answers":{"affected":"1 open source package ship an affected version, including vtk. It affects 1 product.","exploited":"There is no known exploitation of CVE-2025-57106 in the wild and no public exploit code.","fix":"Upgrade vtk to 9.5.1 or later.","what":"CVE-2025-57106 is a high-severity memory corruption vulnerability in n/a, published on 31 Oct 2025. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-57106 and fix it if it is affected.\n\nWhat it is: CVE-2025-57106 is a high-severity memory corruption vulnerability in n/a, published on 31 Oct 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2025-57106 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- vtk (PyPI): affected all versions; fixed in 9.5.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-57106/ (Markdown: https://insights.sbomify.com/CVE-2025-57106/index.md)","id":"CVE-2025-57106","markdown":"https://insights.sbomify.com/CVE-2025-57106/index.md","name":"CVE-2025-57106","record":{"aliases":["DEBIAN-CVE-2025-57106","GHSA-5pfc-43r5-qrmg","PYSEC-2025-224","UBUNTU-CVE-2025-57106"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution","denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"VTK visualization library","requires_auth":"none","summary":"A buffer overflow in the VTK library allows attackers to execute arbitrary code or cause denial of service via malicious GLTF files.","user_interaction":"not_required","vuln_class":"memory_corruption"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"vtk","vendor":"vtk"}],"cvss":{"score":7.5,"severity":"high","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-122","name":"Heap-based Buffer Overflow"}],"description":"Kitware VTK (Visualization Toolkit) up to 9.5.0 is vulnerable to Buffer Overflow in vtkGLTFDocumentLoader. The vulnerability occurs in the BufferDataExtractionWorker template function when processing GLTF accessor data.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Memory corruption in n/a","id":"CVE-2025-57106","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"memory_corruption","year":"2025"},"n_packages":1,"n_references":2,"next":{"headline":"Memory corruption in n/a","id":"CVE-2025-57107"},"packages":[{"ecosystem":"PyPI","fixed":["9.5.1"],"introduced":["0"],"last_affected":[],"package":"vtk","purl":"pkg:pypi/vtk","source":"PYSEC-2025-224"}],"prev":{"headline":"Command injection in n/a","id":"CVE-2025-57105"},"products":["n/a"],"published":"2025-10-31","related":[{"cvss_score":9.8,"headline":"Use after free in n/a","id":"CVE-2025-57108","kev_date_added":null,"published":"2025-10-31"},{"cvss_score":7.5,"headline":"VTK NULL pointer dereference vulnerability","id":"CVE-2021-42521","kev_date_added":null,"published":"2022-08-25"},{"cvss_score":7.1,"headline":"Memory corruption in n/a","id":"CVE-2025-57107","kev_date_added":null,"published":"2025-10-31"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-10-31","vendors":["n/a"]},"summary":"A buffer overflow in the VTK library allows attackers to execute arbitrary code or cause denial of service via malicious GLTF files.","url":"https://insights.sbomify.com/CVE-2025-57106/"}