# CVE-2025-57106: Memory corruption in n/a

> A buffer overflow in the VTK library allows attackers to execute arbitrary code or cause denial of service via malicious GLTF files.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 31 Oct 2025
- **Updated:** 31 Oct 2025
- **Also known as:** DEBIAN-CVE-2025-57106, GHSA-5pfc-43r5-qrmg, PYSEC-2025-224, UBUNTU-CVE-2025-57106

## What is CVE-2025-57106?

CVE-2025-57106 is a high-severity memory corruption vulnerability in n/a, published on 31 Oct 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Kitware VTK (Visualization Toolkit) up to 9.5.0 is vulnerable to Buffer Overflow in vtkGLTFDocumentLoader. The vulnerability occurs in the BufferDataExtractionWorker template function when processing GLTF accessor data.

Weakness: CWE-122 (Heap-based Buffer Overflow)

## Which versions are affected by CVE-2025-57106?

1 open source package ship an affected version, including vtk. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `vtk` | PyPI | All versions | 9.5.1 |

Products: Vtk Vtk.

## How do I fix CVE-2025-57106?

Upgrade vtk to 9.5.1 or later.

## Is CVE-2025-57106 being exploited?

There is no known exploitation of CVE-2025-57106 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2025-57108](https://insights.sbomify.com/CVE-2025-57108/): Use after free in n/a (critical 9.8)
- [CVE-2021-42521](https://insights.sbomify.com/CVE-2021-42521/): VTK NULL pointer dereference vulnerability (high 7.5)
- [CVE-2025-57107](https://insights.sbomify.com/CVE-2025-57107/): Memory corruption in n/a (high 7.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-57106 and fix it if it is affected.

What it is: CVE-2025-57106 is a high-severity memory corruption vulnerability in n/a, published on 31 Oct 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-57106 in the wild and no public exploit code.

Affected packages and fixed versions:
- vtk (PyPI): affected all versions; fixed in 9.5.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-57106/ (Markdown: https://insights.sbomify.com/CVE-2025-57106/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-57106
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-57106
- OSV: https://osv.dev/vulnerability/CVE-2025-57106

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-57106/
Summaries are generated and may contain mistakes; the official description above is the record.
