{"answers":{"affected":"1 open source package ship an affected version, including vtk. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-57107 exists.","fix":"Upgrade vtk to 9.5.1 or later.","what":"CVE-2025-57107 is a high-severity memory corruption vulnerability in n/a, published on 31 Oct 2025. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2025-57107 and fix it if it is affected.\n\nWhat it is: CVE-2025-57107 is a high-severity memory corruption vulnerability in n/a, published on 31 Oct 2025. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-57107 exists.\n\nAffected packages and fixed versions:\n- vtk (PyPI): affected all versions; fixed in 9.5.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-57107/ (Markdown: https://insights.sbomify.com/CVE-2025-57107/index.md)","id":"CVE-2025-57107","markdown":"https://insights.sbomify.com/CVE-2025-57107/index.md","name":"CVE-2025-57107","record":{"aliases":["DEBIAN-CVE-2025-57107","GHSA-6hj2-fxwr-rvj5","PYSEC-2025-225","UBUNTU-CVE-2025-57107"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution","denial_of_service"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"VTK visualization library","requires_auth":"none","summary":"Heap buffer overflow in VTK allows attackers to execute arbitrary code or cause denial of service via crafted GLTF files.","user_interaction":"required","vuln_class":"memory_corruption"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"vtk","vendor":"vtk"}],"cvss":{"score":7.1,"severity":"high","source":"cisa-adp","vector":"CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-122","name":"Heap-based Buffer Overflow"}],"description":"Kitware VTK (Visualization Toolkit) through 9.5.0 contains a heap buffer overflow vulnerability in vtkGLTFDocumentLoader. When processing specially crafted GLTF files, the copy constructor of Accessor objects fails to properly validate buffer boundaries before performing memory read operations.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Memory corruption in n/a","id":"CVE-2025-57107","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"memory_corruption","year":"2025"},"n_packages":1,"n_references":1,"next":{"headline":"Use after free in n/a","id":"CVE-2025-57108"},"packages":[{"ecosystem":"PyPI","fixed":["9.5.1"],"introduced":["0"],"last_affected":[],"package":"vtk","purl":"pkg:pypi/vtk","source":"PYSEC-2025-225"}],"prev":{"headline":"Memory corruption in n/a","id":"CVE-2025-57106"},"products":["n/a"],"published":"2025-10-31","related":[{"cvss_score":9.8,"headline":"Use after free in n/a","id":"CVE-2025-57108","kev_date_added":null,"published":"2025-10-31"},{"cvss_score":7.5,"headline":"Memory corruption in n/a","id":"CVE-2025-57106","kev_date_added":null,"published":"2025-10-31"},{"cvss_score":7.5,"headline":"VTK NULL pointer dereference vulnerability","id":"CVE-2021-42521","kev_date_added":null,"published":"2022-08-25"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-10-31","vendors":["n/a"]},"summary":"Heap buffer overflow in VTK allows attackers to execute arbitrary code or cause denial of service via crafted GLTF files.","url":"https://insights.sbomify.com/CVE-2025-57107/"}