# CVE-2025-57107: Memory corruption in n/a

> Heap buffer overflow in VTK allows attackers to execute arbitrary code or cause denial of service via crafted GLTF files.

- **Severity:** High 7.1 (`CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 31 Oct 2025
- **Updated:** 31 Oct 2025
- **Also known as:** DEBIAN-CVE-2025-57107, GHSA-6hj2-fxwr-rvj5, PYSEC-2025-225, UBUNTU-CVE-2025-57107

## What is CVE-2025-57107?

CVE-2025-57107 is a high-severity memory corruption vulnerability in n/a, published on 31 Oct 2025. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

Kitware VTK (Visualization Toolkit) through 9.5.0 contains a heap buffer overflow vulnerability in vtkGLTFDocumentLoader. When processing specially crafted GLTF files, the copy constructor of Accessor objects fails to properly validate buffer boundaries before performing memory read operations.

Weakness: CWE-122 (Heap-based Buffer Overflow)

## Which versions are affected by CVE-2025-57107?

1 open source package ship an affected version, including vtk. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `vtk` | PyPI | All versions | 9.5.1 |

Products: Vtk Vtk.

## How do I fix CVE-2025-57107?

Upgrade vtk to 9.5.1 or later.

## Is CVE-2025-57107 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-57107 exists.

## Other vulnerabilities in n/a

- [CVE-2025-57108](https://insights.sbomify.com/CVE-2025-57108/): Use after free in n/a (critical 9.8)
- [CVE-2025-57106](https://insights.sbomify.com/CVE-2025-57106/): Memory corruption in n/a (high 7.5)
- [CVE-2021-42521](https://insights.sbomify.com/CVE-2021-42521/): VTK NULL pointer dereference vulnerability (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-57107 and fix it if it is affected.

What it is: CVE-2025-57107 is a high-severity memory corruption vulnerability in n/a, published on 31 Oct 2025. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-57107 exists.

Affected packages and fixed versions:
- vtk (PyPI): affected all versions; fixed in 9.5.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-57107/ (Markdown: https://insights.sbomify.com/CVE-2025-57107/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-57107
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-57107
- OSV: https://osv.dev/vulnerability/CVE-2025-57107

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-57107/
Summaries are generated and may contain mistakes; the official description above is the record.
