CVE-2025-57164 FlowiseAI Pre-Auth Arbitrary Code Execution
Attackers can execute arbitrary code remotely by exploiting unsanitized input in the Supabase RPC Filter field of Flowise.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2025-57164?
CVE-2025-57164 is a medium-severity command injection vulnerability in Flowiseai Flowise, published on 17 Oct 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Flowise through v3.0.4 is vulnerable to remote code execution via unsanitized evaluation of user input in the "Supabase RPC Filter" field.
Weakness: CWE-77
Which versions are affected by CVE-2025-57164?
2 open source packages ship an affected version, including flowise. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
flowise npm | From 3.0.5 | 3.0.6 |
flowise npm | From 3.0.5 | 3.0.6 |
Products include Flowiseai Flowise.
How do I fix CVE-2025-57164?
Upgrade flowise to 3.0.6 or later.
Upgrade, and pass arguments to programs as a list instead of through a shell. More about Command injection.
Is CVE-2025-57164 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-57164 exists.
Other vulnerabilities in Flowiseai Flowise
- CVE-2025-71338 Flowise through 2.2.7 - Arbitrary File Write to Remote Code Execution via document-store API
- CVE-2026-40933 Flowise: Authenticated RCE Via MCP Adapters
- CVE-2025-61913 Flowise is vulnerable to arbitrary file read, arbitrary file write
- CVE-2025-59528 Flowise has Remote Code Execution vulnerability
- CVE-2026-52098 Code injection in n/a
Sources
Also known as GHSA-7944-7c6r-55vv.