CVE-2025-57275 SPDK is vulnerable to buffer overflow in the NVMe-oF target component

Medium 5.5 Published Updated

A buffer overflow in the SPDK NVMe-oF target allows attackers to execute arbitrary code or cause denial of service.

Exploited in the wild
Not known
Login needed
An administrator
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2025-57275?

CVE-2025-57275 is a medium-severity memory corruption vulnerability in n/a, published on 1 Oct 2025. An attacker needs administrator access to exploit it, with no action from the victim.

Official description

Storage Performance Development Kit (SPDK) 25.05 is vulnerable to Buffer Overflow in the NVMe-oF target component in SPDK - lib/nvmf.

Weakness: CWE-120

Which versions are affected by CVE-2025-57275?

3 open source packages ship an affected version, including spdk.

PackageAffectedFixed in
spdk PyPIAll versions25.9
spdk PyPIAll versions25.9
spdk PyPIAll versions25.9

How do I fix CVE-2025-57275?

Upgrade spdk to 25.9 or later.

Upgrade to the fixed version. Memory-safe languages, compiler hardening and fuzzing prevent most new cases. More about Memory corruption.

Is CVE-2025-57275 being exploited?

There is no known exploitation of CVE-2025-57275 in the wild and no public exploit code.

Sources

Also known as GHSA-5m5w-w2h2-fqgq, OESA-2025-2523, OESA-2025-2524, OESA-2025-2525, OESA-2025-2692, OESA-2025-2693 and 1 more.

Is CVE-2025-57275 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free