# CVE-2025-57285: CodeceptJS's incomprehensive sanitation can lead to Command Injection

> Attackers can execute arbitrary commands via unsanitized input in the emptyFolder function of the CodeceptJS testing library.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 8 Sep 2025
- **Updated:** 8 Sep 2025
- **Also known as:** GHSA-34w8-mcwr-vg29

## What is CVE-2025-57285?

CVE-2025-57285 is a critical command injection vulnerability in n/a, published on 8 Sep 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

codeceptjs 3.7.3 contains a command injection vulnerability in the emptyFolder function (lib/utils.js). The execSync command directly concatenates the user-controlled directoryPath parameter without sanitization or escaping, allowing attackers to execute arbitrary commands.

Weakness: CWE-77 (Improper Neutralization of Special Elements used in a Command)

## Which versions are affected by CVE-2025-57285?

2 open source packages ship an affected version, including codeceptjs. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `codeceptjs` | npm | From 3.5.0 | 3.7.5 |
| `codeceptjs` | npm | From 3.5.0 | 3.7.5 |

Products: Codecept Codeceptjs.

## How do I fix CVE-2025-57285?

Upgrade codeceptjs to 3.7.5 or later.

## Is CVE-2025-57285 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-57285 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-57285 and fix it if it is affected.

What it is: CVE-2025-57285 is a critical command injection vulnerability in n/a, published on 8 Sep 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-57285 exists.

Affected packages and fixed versions:
- codeceptjs (npm): affected from 3.5.0; fixed in 3.7.5
- codeceptjs (npm): affected from 3.5.0; fixed in 3.7.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-57285/ (Markdown: https://insights.sbomify.com/CVE-2025-57285/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-57285
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-57285
- OSV: https://osv.dev/vulnerability/CVE-2025-57285

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-57285/
Summaries are generated and may contain mistakes; the official description above is the record.
