# CVE-2025-57352: min-document vulnerable to prototype pollution


- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 24 Sep 2025
- **Updated:** 25 Sep 2025
- **Also known as:** DEBIAN-CVE-2025-57352, GHSA-rx8g-88g5-qh64, MINI-qwpj-q2fv-hh8p, MINI-rwm5-8964-4wcr, MINI-wpfp-274h-v47j, UBUNTU-CVE-2025-57352

## What is CVE-2025-57352?

CVE-2025-57352 is a medium-severity vulnerability in n/a, published on 24 Sep 2025. 

### Official description

A vulnerability exists in the 'min-document' package prior to version 2.19.0, stemming from improper handling of namespace operations in the removeAttributeNS method. By processing malicious input involving the __proto__ property, an attacker can manipulate the prototype chain of JavaScript objects, leading to denial of service or arbitrary code execution. This issue arises from insufficient validation of attribute namespace removal operations, allowing unintended modification of critical object prototypes. The vulnerability remains unaddressed in the latest available version.

Weakness: CWE-1321 (Improperly Controlled Modification of Object Prototype Attributes)

## Which versions are affected by CVE-2025-57352?

2 open source packages ship an affected version, including min-document.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `min-document` | npm | All versions | 2.19.1 |
| `min-document` | npm | All versions | 2.19.1 |

## How do I fix CVE-2025-57352?

Upgrade min-document to 2.19.1 or later.

## Is CVE-2025-57352 being exploited?

There is no known exploitation of CVE-2025-57352 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-57352 and fix it if it is affected.

What it is: CVE-2025-57352 is a medium-severity vulnerability in n/a, published on 24 Sep 2025. 
Exploitation: There is no known exploitation of CVE-2025-57352 in the wild and no public exploit code.

Affected packages and fixed versions:
- min-document (npm): affected all versions; fixed in 2.19.1
- min-document (npm): affected all versions; fixed in 2.19.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-57352/ (Markdown: https://insights.sbomify.com/CVE-2025-57352/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-57352
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-57352
- OSV: https://osv.dev/vulnerability/CVE-2025-57352

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-57352/
Summaries are generated and may contain mistakes; the official description above is the record.
