# CVE-2025-57353: messageformat prototype pollution vulnerability

> Prototype pollution in the messageformat library allows attackers to inject properties into Object.prototype, causing denial of service or unexpected behavior.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 24 Sep 2025
- **Updated:** 5 Nov 2025
- **Also known as:** GHSA-6xv4-9cqp-92rh

## What is CVE-2025-57353?

CVE-2025-57353 is a medium-severity vulnerability in n/a, published on 24 Sep 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The Runtime components of messageformat package for Node.js before 3.0.2 contain a prototype pollution vulnerability. Due to insufficient validation of nested message keys during the processing of message data, an attacker can manipulate the prototype chain of JavaScript objects by providing specially crafted input. This can result in the injection of arbitrary properties into the Object.prototype, potentially leading to denial of service conditions or unexpected application behavior. The vulnerability allows attackers to alter the prototype of base objects, impacting all subsequent object instances throughout the application's lifecycle.

Weakness: CWE-1321 (Improperly Controlled Modification of Object Prototype Attributes)

## Which versions are affected by CVE-2025-57353?

2 open source packages ship an affected version, including @messageformat/runtime.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@messageformat/runtime` | npm | From 3.0.1 | 3.0.2 |
| `@messageformat/runtime` | npm | From 3.0.1 | 3.0.2 |

## How do I fix CVE-2025-57353?

Upgrade @messageformat/runtime to 3.0.2 or later.

## Is CVE-2025-57353 being exploited?

There is no known exploitation of CVE-2025-57353 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-57353 and fix it if it is affected.

What it is: CVE-2025-57353 is a medium-severity vulnerability in n/a, published on 24 Sep 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-57353 in the wild and no public exploit code.

Affected packages and fixed versions:
- @messageformat/runtime (npm): affected from 3.0.1; fixed in 3.0.2
- @messageformat/runtime (npm): affected from 3.0.1; fixed in 3.0.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-57353/ (Markdown: https://insights.sbomify.com/CVE-2025-57353/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-57353
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-57353
- OSV: https://osv.dev/vulnerability/CVE-2025-57353

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-57353/
Summaries are generated and may contain mistakes; the official description above is the record.
