CVE-2025-57407 GP247 and S-Cart have a stored cross-site scripting (XSS) vulnerability
Authenticated attackers can inject scripts via User-Agent headers in S-Cart's Admin Log Viewer, leading to admin session hijacking.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2025-57407?
CVE-2025-57407 is a medium-severity cross-site scripting vulnerability in n/a, published on 23 Sep 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Official description
A stored cross-site scripting (XSS) vulnerability in the Admin Log Viewer of S-Cart <=10.0.3 allows a remote authenticated attacker to inject arbitrary web script or HTML via a crafted User-Agent header. The script is executed in an administrator's browser when they view the security log page, which could lead to session hijacking or other malicious actions.
Weakness: CWE-79
Which versions are affected by CVE-2025-57407?
4 open source packages ship an affected version, including gp247/core and s-cart/core. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
gp247/core Packagist | All versions | 1.1.24 |
gp247/core Packagist | All versions | 1.1.24 |
s-cart/core Packagist | All versions to 9.0.5 | None |
s-cart/core Packagist | All versions to 9.0.5 | None |
Products include Gp247 Gp247.
How do I fix CVE-2025-57407?
Upgrade gp247/core to 1.1.24 or later.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2025-57407 being exploited?
There is no known exploitation of CVE-2025-57407 in the wild and no public exploit code.
Sources
Also known as GHSA-46v4-5mc8-q2cf.