{"answers":{"affected":"4 open source packages ship an affected version, including gp247/core and s-cart/core. It affects 1 product.","exploited":"There is no known exploitation of CVE-2025-57407 in the wild and no public exploit code.","fix":"Upgrade gp247/core to 1.1.24 or later.","what":"CVE-2025-57407 is a medium-severity cross-site scripting vulnerability in n/a, published on 23 Sep 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2025-57407 and fix it if it is affected.\n\nWhat it is: CVE-2025-57407 is a medium-severity cross-site scripting vulnerability in n/a, published on 23 Sep 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2025-57407 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- gp247/core (Packagist): affected all versions; fixed in 1.1.24\n- gp247/core (Packagist): affected all versions; fixed in 1.1.24\n- s-cart/core (Packagist): affected all versions up to 9.0.5; no fix listed\n- s-cart/core (Packagist): affected all versions up to 9.0.5; no fix listed\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-57407/ (Markdown: https://insights.sbomify.com/CVE-2025-57407/index.md)","id":"CVE-2025-57407","markdown":"https://insights.sbomify.com/CVE-2025-57407/index.md","name":"CVE-2025-57407","record":{"aliases":["GHSA-46v4-5mc8-q2cf"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["account_takeover","code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"S-Cart e-commerce","requires_auth":"low_privilege","summary":"Authenticated attackers can inject scripts via User-Agent headers in S-Cart's Admin Log Viewer, leading to admin session hijacking.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"gp247","vendor":"gp247"}],"cvss":{"score":5.4,"severity":"medium","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"A stored cross-site scripting (XSS) vulnerability in the Admin Log Viewer of S-Cart \u003c=10.0.3 allows a remote authenticated attacker to inject arbitrary web script or HTML via a crafted User-Agent header. The script is executed in an administrator's browser when they view the security log page, which could lead to session hijacking or other malicious actions.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"GP247 and S-Cart have a stored cross-site scripting (XSS) vulnerability","id":"CVE-2025-57407","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"xss","year":"2025"},"n_packages":4,"n_references":2,"next":{"headline":"SQL injection in n/a","id":"CVE-2025-57423"},"packages":[{"ecosystem":"Packagist","fixed":["1.1.24"],"introduced":["0"],"last_affected":[],"package":"gp247/core","purl":null,"source":"GHSA-46v4-5mc8-q2cf"},{"ecosystem":"Packagist","fixed":["1.1.24"],"introduced":["0"],"last_affected":[],"package":"gp247/core","purl":"pkg:composer/gp247/core","source":"GHSA-46v4-5mc8-q2cf"},{"ecosystem":"Packagist","fixed":[],"introduced":["0"],"last_affected":["9.0.5"],"package":"s-cart/core","purl":null,"source":"GHSA-46v4-5mc8-q2cf"},{"ecosystem":"Packagist","fixed":[],"introduced":["0"],"last_affected":["9.0.5"],"package":"s-cart/core","purl":"pkg:composer/s-cart/core","source":"GHSA-46v4-5mc8-q2cf"}],"prev":{"headline":"Path traversal in n/a","id":"CVE-2025-57403"},"products":["n/a"],"published":"2025-09-23","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-09-24","vendors":["n/a"]},"summary":"Authenticated attackers can inject scripts via User-Agent headers in S-Cart's Admin Log Viewer, leading to admin session hijacking.","url":"https://insights.sbomify.com/CVE-2025-57407/"}