# CVE-2025-57407: GP247 and S-Cart have a stored cross-site scripting (XSS) vulnerability

> Authenticated attackers can inject scripts via User-Agent headers in S-Cart's Admin Log Viewer, leading to admin session hijacking.

- **Severity:** Medium 5.4 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 23 Sep 2025
- **Updated:** 24 Sep 2025
- **Also known as:** GHSA-46v4-5mc8-q2cf

## What is CVE-2025-57407?

CVE-2025-57407 is a medium-severity cross-site scripting vulnerability in n/a, published on 23 Sep 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

A stored cross-site scripting (XSS) vulnerability in the Admin Log Viewer of S-Cart <=10.0.3 allows a remote authenticated attacker to inject arbitrary web script or HTML via a crafted User-Agent header. The script is executed in an administrator's browser when they view the security log page, which could lead to session hijacking or other malicious actions.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2025-57407?

4 open source packages ship an affected version, including gp247/core and s-cart/core. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `gp247/core` | Packagist | All versions | 1.1.24 |
| `gp247/core` | Packagist | All versions | 1.1.24 |
| `s-cart/core` | Packagist | All versions to 9.0.5 | None |
| `s-cart/core` | Packagist | All versions to 9.0.5 | None |

Products: Gp247 Gp247.

## How do I fix CVE-2025-57407?

Upgrade gp247/core to 1.1.24 or later.

## Is CVE-2025-57407 being exploited?

There is no known exploitation of CVE-2025-57407 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-57407 and fix it if it is affected.

What it is: CVE-2025-57407 is a medium-severity cross-site scripting vulnerability in n/a, published on 23 Sep 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2025-57407 in the wild and no public exploit code.

Affected packages and fixed versions:
- gp247/core (Packagist): affected all versions; fixed in 1.1.24
- gp247/core (Packagist): affected all versions; fixed in 1.1.24
- s-cart/core (Packagist): affected all versions up to 9.0.5; no fix listed
- s-cart/core (Packagist): affected all versions up to 9.0.5; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-57407/ (Markdown: https://insights.sbomify.com/CVE-2025-57407/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-57407
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-57407
- OSV: https://osv.dev/vulnerability/CVE-2025-57407

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-57407/
Summaries are generated and may contain mistakes; the official description above is the record.
