# CVE-2025-57735: Apache Airflow: Airflow Logout Not Invalidating JWT

> Attackers can reuse intercepted JWT tokens after logout to maintain unauthorized access to Apache Airflow instances.

- **Severity:** Critical 9.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 9 Apr 2026
- **Updated:** 9 Apr 2026
- **Also known as:** BIT-airflow-2025-57735, ECHO-667c-b1cf-dd2b, GHSA-c92r-g8j5-vhcx, MINI-rr4q-2wjw-hcrf, PYSEC-2026-269

## What is CVE-2025-57735?

CVE-2025-57735 is a critical vulnerability in Apache Airflow, published on 9 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

When user logged out, the JWT token the user had authtenticated with was not invalidated, which could lead to reuse of that token in case it was intercepted. In Airflow 3.2 we implemented the mechanism that implements token invalidation at logout. Users who are concerned about the logout scenario and possibility of intercepting the tokens, should upgrade to Airflow 3.2+

Users are recommended to upgrade to version 3.2.0, which fixes this issue.

Weakness: CWE-613 (DEPRECATED: Insufficient Session Expiration)

## Which versions are affected by CVE-2025-57735?

4 open source packages ship an affected version, including apache-airflow and airflow. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `apache-airflow` | PyPI | From 3.0.0 | 3.2.0 |
| `apache-airflow` | PyPI | From 3.0.0 | 3.2.0 |
| `apache-airflow` | PyPI | From 3.0.0 | 3.2.0 |
| `airflow` | Bitnami | From 3.0.0 | 3.2.0 |

Products: Apache Airflow.

## How do I fix CVE-2025-57735?

Upgrade apache-airflow to 3.2.0 or later.

## Is CVE-2025-57735 being exploited?

There is no known exploitation of CVE-2025-57735 in the wild and no public exploit code.

## Other vulnerabilities in Apache Airflow

- [CVE-2020-13927](https://insights.sbomify.com/CVE-2020-13927/): Apache Airflow's Experimental API Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2020-11978](https://insights.sbomify.com/CVE-2020-11978/): Apache Airflow Command Injection (high 8.8, exploited in the wild)
- [CVE-2026-33264](https://insights.sbomify.com/CVE-2026-33264/): Apache Airflow: DAG author RCE on webserver via unrestricted import_string() in BaseSerialization.deserialize() (critical 9.8)
- [CVE-2023-25754](https://insights.sbomify.com/CVE-2023-25754/): Apache Airflow: Privilege escalation using airflow logs (critical 9.8)
- [CVE-2023-22884](https://insights.sbomify.com/CVE-2023-22884/): Apache Airflow, Apache Airflow MySQL Provider: Arbitrary file read via MySQL provider in Apache Airflow (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-57735 and fix it if it is affected.

What it is: CVE-2025-57735 is a critical vulnerability in Apache Airflow, published on 9 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-57735 in the wild and no public exploit code.

Affected packages and fixed versions:
- apache-airflow (PyPI): affected from 3.0.0; fixed in 3.2.0
- apache-airflow (PyPI): affected from 3.0.0; fixed in 3.2.0
- apache-airflow (PyPI): affected from 3.0.0; fixed in 3.2.0
- airflow (Bitnami): affected from 3.0.0; fixed in 3.2.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-57735/ (Markdown: https://insights.sbomify.com/CVE-2025-57735/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-57735
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-57735
- OSV: https://osv.dev/vulnerability/CVE-2025-57735

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-57735/
Summaries are generated and may contain mistakes; the official description above is the record.
