# CVE-2025-57751: Denial-of-Service attack in pyLoad CNL Blueprint using dukpy.evaljs

> Attackers can cause a denial of service in pyLoad by sending malicious input to the jk parameter, leading to high CPU usage and unresponsiveness.

- **Severity:** High 7.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N/E:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 21 Aug 2025
- **Updated:** 21 Aug 2025
- **Also known as:** GHSA-9gjj-6gj7-c4wj, PYSEC-2026-1815

## What is CVE-2025-57751?

CVE-2025-57751 is a high-severity denial of service vulnerability in pyload, published on 21 Aug 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

pyLoad is the free and open-source Download Manager written in pure Python. The jk parameter is received in pyLoad CNL Blueprint. Due to the lack of jk parameter verification, the jk parameter input by the user is directly determined as dykpy.evaljs(), resulting in the server CPU being fully occupied and the web-ui becoming unresponsive. This vulnerability is fixed in 0.5.0b3.dev92.

Weakness: CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2025-57751?

3 open source packages ship an affected version, including pyload-ng.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pyload-ng` | PyPI | All versions | 0.5.0b3.dev92 |
| `pyload-ng` | PyPI | All versions | 0.5.0b3.dev92 |
| `pyload-ng` | PyPI | All versions | 0.5.0b3.dev92 |

## How do I fix CVE-2025-57751?

Upgrade pyload-ng to 0.5.0b3.dev92 or later.

## Is CVE-2025-57751 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-57751 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-57751 and fix it if it is affected.

What it is: CVE-2025-57751 is a high-severity denial of service vulnerability in pyload, published on 21 Aug 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-57751 exists.

Affected packages and fixed versions:
- pyload-ng (PyPI): affected all versions; fixed in 0.5.0b3.dev92
- pyload-ng (PyPI): affected all versions; fixed in 0.5.0b3.dev92
- pyload-ng (PyPI): affected all versions; fixed in 0.5.0b3.dev92

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-57751/ (Markdown: https://insights.sbomify.com/CVE-2025-57751/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-57751
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-57751
- OSV: https://osv.dev/vulnerability/CVE-2025-57751

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-57751/
Summaries are generated and may contain mistakes; the official description above is the record.
