# CVE-2025-57752: Next.js Affected by Cache Key Confusion for Image Optimization API Routes

> Attackers can access unauthorized cached image responses from API routes if image optimization is enabled and responses vary by request headers.

- **Severity:** Medium 6.2 (`CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 29 Aug 2025
- **Updated:** 2 Sep 2025
- **Also known as:** GHSA-g5qg-72qw-gw5v, MINI-6f28-m59g-77q8, ROOT-APP-NPM-CVE-2025-57752

## What is CVE-2025-57752?

CVE-2025-57752 is a medium-severity vulnerability in Vercel Next.js, published on 29 Aug 2025. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

Next.js is a React framework for building full-stack web applications. In versions before 14.2.31 and from 15.0.0 to before 15.4.5, Next.js Image Optimization API routes are affected by cache key confusion. When images returned from API routes vary based on request headers (such as Cookie or Authorization), these responses could be incorrectly cached and served to unauthorized users due to a cache key confusion bug. This vulnerability has been fixed in Next.js versions 14.2.31 and 15.4.5. All users are encouraged to upgrade if they use API routes to serve images that depend on request headers and have image optimization enabled.

Weakness: CWE-524 (Use of Cache Containing Sensitive Information)

## Which versions are affected by CVE-2025-57752?

4 open source packages ship an affected version, including next. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `next` | npm | From 0.9.9 | 14.2.31 |
| `next` | npm | From 0.9.9 | 14.2.31 |
| `next` | npm | From 15.0.0 | 15.4.5 |
| `next` | npm | From 15.0.0 | 15.4.5 |

Products: Vercel Next.js.

## How do I fix CVE-2025-57752?

Upgrade next to a fixed version for your release line: 14.2.31 or 15.4.5.

## Is CVE-2025-57752 being exploited?

There is no known exploitation of CVE-2025-57752 in the wild and no public exploit code.

## Other vulnerabilities in Vercel Next.js

- [CVE-2025-29927](https://insights.sbomify.com/CVE-2025-29927/): Authorization Bypass in Next.js Middleware (critical 9.1)
- [CVE-2026-44578](https://insights.sbomify.com/CVE-2026-44578/): Next.js: Server-side request forgery in applications using WebSocket upgrades (high 8.6)
- [CVE-2026-94483](https://insights.sbomify.com/CVE-2026-94483/): Next.js: Server-Side Request Forgery in Image Optimization (high 8.3)
- [CVE-2026-64642](https://insights.sbomify.com/CVE-2026-64642/): Next.js: Middleware / Proxy bypass in App Router applications using Turbopack and single locale (high 8.3)
- [CVE-2026-64645](https://insights.sbomify.com/CVE-2026-64645/): Next.js: Server-Side Request Forgery in rewrites via attacker-controlled destination hostname (high 8.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-57752 and fix it if it is affected.

What it is: CVE-2025-57752 is a medium-severity vulnerability in Vercel Next.js, published on 29 Aug 2025. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-57752 in the wild and no public exploit code.

Affected packages and fixed versions:
- next (npm): affected from 0.9.9; fixed in 14.2.31
- next (npm): affected from 0.9.9; fixed in 14.2.31
- next (npm): affected from 15.0.0; fixed in 15.4.5
- next (npm): affected from 15.0.0; fixed in 15.4.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-57752/ (Markdown: https://insights.sbomify.com/CVE-2025-57752/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-57752
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-57752
- OSV: https://osv.dev/vulnerability/CVE-2025-57752

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-57752/
Summaries are generated and may contain mistakes; the official description above is the record.
