{"answers":{"affected":"2 open source packages ship an affected version, including @musistudio/claude-code-router.","exploited":"There is no known exploitation of CVE-2025-57755 in the wild and no public exploit code.","fix":"Upgrade @musistudio/claude-code-router to 1.0.34 or later.","what":"CVE-2025-57755 is a high-severity vulnerability in musistudio claude-code-router, published on 21 Aug 2025. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-57755 and fix it if it is affected.\n\nWhat it is: CVE-2025-57755 is a high-severity vulnerability in musistudio claude-code-router, published on 21 Aug 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2025-57755 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- @musistudio/claude-code-router (npm): affected all versions; fixed in 1.0.34\n- @musistudio/claude-code-router (npm): affected all versions; fixed in 1.0.34\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-57755/ (Markdown: https://insights.sbomify.com/CVE-2025-57755/index.md)","id":"CVE-2025-57755","markdown":"https://insights.sbomify.com/CVE-2025-57755/index.md","name":"CVE-2025-57755","record":{"aliases":["GHSA-8hmm-4crw-vm2c"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"Claude Code router","requires_auth":"none","summary":"Improper CORS configuration in claude-code-router allows attackers to steal API keys and access sensitive data from untrusted domains.","user_interaction":"not_required","vuln_class":"misconfiguration"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":8.1,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:U","version":"4.0"},"cwes":[{"id":"CWE-942","name":"Permissive Cross-domain Security Policy with Untrusted Domains"},{"id":"CWE-200","name":"Exposure of Sensitive Information to an Unauthorized Actor"}],"description":"claude-code-router is a powerful tool to route Claude Code requests to different models and customize any request. Due to improper Cross-Origin Resource Sharing (CORS) configuration, there is a risk that user API Keys or equivalent credentials may be exposed to untrusted domains. Attackers could exploit this misconfiguration to steal credentials, abuse accounts, exhaust quotas, or access sensitive data. The issue has been patched in v1.0.34.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"claude-code-router CORS. misconfiguration","id":"CVE-2025-57755","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"misconfiguration","year":"2025"},"n_packages":2,"n_references":1,"next":{"headline":"Contao discloses sensitive information in the front end search index","id":"CVE-2025-57756"},"packages":[{"ecosystem":"npm","fixed":["1.0.34"],"introduced":["0"],"last_affected":[],"package":"@musistudio/claude-code-router","purl":null,"source":"GHSA-8hmm-4crw-vm2c"},{"ecosystem":"npm","fixed":["1.0.34"],"introduced":["0"],"last_affected":[],"package":"@musistudio/claude-code-router","purl":"pkg:npm/%40musistudio/claude-code-router","source":"GHSA-8hmm-4crw-vm2c"}],"prev":{"headline":"eslint-ban-moment exposed a sensitive Supabase URI in .env (Credential leak)","id":"CVE-2025-57754"},"products":["claude-code-router"],"published":"2025-08-21","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-08-21","vendors":["musistudio"]},"summary":"Improper CORS configuration in claude-code-router allows attackers to steal API keys and access sensitive data from untrusted domains.","url":"https://insights.sbomify.com/CVE-2025-57755/"}