# CVE-2025-57755: claude-code-router CORS. misconfiguration

> Improper CORS configuration in claude-code-router allows attackers to steal API keys and access sensitive data from untrusted domains.

- **Severity:** High 8.1 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:U`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 21 Aug 2025
- **Updated:** 21 Aug 2025
- **Also known as:** GHSA-8hmm-4crw-vm2c

## What is CVE-2025-57755?

CVE-2025-57755 is a high-severity vulnerability in musistudio claude-code-router, published on 21 Aug 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

claude-code-router is a powerful tool to route Claude Code requests to different models and customize any request. Due to improper Cross-Origin Resource Sharing (CORS) configuration, there is a risk that user API Keys or equivalent credentials may be exposed to untrusted domains. Attackers could exploit this misconfiguration to steal credentials, abuse accounts, exhaust quotas, or access sensitive data. The issue has been patched in v1.0.34.

Weakness: CWE-942 (Permissive Cross-domain Security Policy with Untrusted Domains), CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2025-57755?

2 open source packages ship an affected version, including @musistudio/claude-code-router.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@musistudio/claude-code-router` | npm | All versions | 1.0.34 |
| `@musistudio/claude-code-router` | npm | All versions | 1.0.34 |

## How do I fix CVE-2025-57755?

Upgrade @musistudio/claude-code-router to 1.0.34 or later.

## Is CVE-2025-57755 being exploited?

There is no known exploitation of CVE-2025-57755 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-57755 and fix it if it is affected.

What it is: CVE-2025-57755 is a high-severity vulnerability in musistudio claude-code-router, published on 21 Aug 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-57755 in the wild and no public exploit code.

Affected packages and fixed versions:
- @musistudio/claude-code-router (npm): affected all versions; fixed in 1.0.34
- @musistudio/claude-code-router (npm): affected all versions; fixed in 1.0.34

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-57755/ (Markdown: https://insights.sbomify.com/CVE-2025-57755/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-57755
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-57755
- OSV: https://osv.dev/vulnerability/CVE-2025-57755

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-57755/
Summaries are generated and may contain mistakes; the official description above is the record.
