CVE-2025-57756 Contao discloses sensitive information in the front end search index
Attackers can access protected content elements via the front end search index in Contao CMS, exposing sensitive information.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2025-57756?
CVE-2025-57756 is a medium-severity vulnerability in contao, published on 28 Aug 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Contao is an Open Source CMS. In versions starting from 4.9.14 and prior to 4.13.56, 5.3.38, and 5.6.1, protected content elements that are rendered as fragments are indexed and become publicly available in the front end search. This issue has been patched in versions 4.13.56, 5.3.38, and 5.6.1. A workaround involves disabling the front end search.
Which versions are affected by CVE-2025-57756?
12 open source packages ship an affected version, including contao/contao and contao/core-bundle. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
contao/contao Packagist | From 4.9.14 | 4.13.56 |
contao/contao Packagist | From 4.9.14 | 4.13.56 |
contao/contao Packagist | From 5.0.0-RC1 | 5.3.38 |
contao/contao Packagist | From 5.0.0-RC1 | 5.3.38 |
contao/contao Packagist | From 5.4.0-RC1 | 5.6.1 |
contao/contao Packagist | From 5.4.0-RC1 | 5.6.1 |
6 more packages
contao/core-bundle Packagist | From 4.9.14 | 4.13.56 |
contao/core-bundle Packagist | From 4.9.14 | 4.13.56 |
contao/core-bundle Packagist | From 5.0.0-RC1 | 5.3.38 |
contao/core-bundle Packagist | From 5.0.0-RC1 | 5.3.38 |
contao/core-bundle Packagist | From 5.4.0-RC1 | 5.6.1 |
contao/core-bundle Packagist | From 5.4.0-RC1 | 5.6.1 |
Products include Contao Contao.
How do I fix CVE-2025-57756?
Upgrade contao/contao to a fixed version for your release line: 4.13.56, 5.3.38 or 5.6.1.
Is CVE-2025-57756 being exploited?
There is no known exploitation of CVE-2025-57756 in the wild and no public exploit code.
Other vulnerabilities in contao
- CVE-2022-26265 Remote Code Execution in Contao Managed Edition
- CVE-2019-11512 Contao SQL injection in the file manager
- CVE-2012-4383 Contao core SQL Injection Vulnerability
- CVE-2019-19745 Unrestricted file uploads in Contao
- CVE-2024-28235 Contao possible cookie sharing with external domains while checking protected pages for broken links
Sources
Also known as GHSA-2xmj-8wmq-7475.