CVE-2025-57757 Contao discloses information in the news module

Medium 5.3 Published Updated

Attackers can access protected news items via RSS feeds in Contao CMS, exposing confidential content to the public.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2025-57757?

CVE-2025-57757 is a medium-severity vulnerability in contao, published on 28 Aug 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Contao is an Open Source CMS. In versions starting from 5.0.0 and prior to 5.3.38 and 5.6.1, if a news feed contains protected news archives, their news items are not filtered and become publicly available in the RSS feed. This issue has been patched in versions 5.3.38 and 5.6.1. A workaround involves not adding protected news archives to the news feed page.

Weakness: CWE-212, CWE-200

Which versions are affected by CVE-2025-57757?

8 open source packages ship an affected version, including contao/contao and contao/core-bundle. It affects 1 product.

PackageAffectedFixed in
contao/contao PackagistFrom 5.0.0-RC15.3.38
contao/contao PackagistFrom 5.0.0-RC15.3.38
contao/contao PackagistFrom 5.4.0-RC15.6.1
contao/contao PackagistFrom 5.4.0-RC15.6.1
contao/core-bundle PackagistFrom 5.0.0-RC15.3.38
contao/core-bundle PackagistFrom 5.0.0-RC15.3.38
2 more packages
contao/core-bundle PackagistFrom 5.4.0-RC15.6.1
contao/core-bundle PackagistFrom 5.4.0-RC15.6.1

Products include Contao Contao.

How do I fix CVE-2025-57757?

Upgrade contao/contao to a fixed version for your release line: 5.3.38 or 5.6.1.

Is CVE-2025-57757 being exploited?

There is no known exploitation of CVE-2025-57757 in the wild and no public exploit code.

Sources

Also known as GHSA-w53m-gxvg-vx7p.

Is CVE-2025-57757 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free