# CVE-2025-57757: Contao discloses information in the news module

> Attackers can access protected news items via RSS feeds in Contao CMS, exposing confidential content to the public.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 28 Aug 2025
- **Updated:** 28 Aug 2025
- **Also known as:** GHSA-w53m-gxvg-vx7p

## What is CVE-2025-57757?

CVE-2025-57757 is a medium-severity vulnerability in contao, published on 28 Aug 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Contao is an Open Source CMS. In versions starting from 5.0.0 and prior to 5.3.38 and 5.6.1, if a news feed contains protected news archives, their news items are not filtered and become publicly available in the RSS feed. This issue has been patched in versions 5.3.38 and 5.6.1. A workaround involves not adding protected news archives to the news feed page.

Weakness: CWE-212 (Improper Removal of Sensitive Information Before Storage or Transfer), CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2025-57757?

8 open source packages ship an affected version, including contao/contao and contao/core-bundle. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `contao/contao` | Packagist | From 5.0.0-RC1 | 5.3.38 |
| `contao/contao` | Packagist | From 5.0.0-RC1 | 5.3.38 |
| `contao/contao` | Packagist | From 5.4.0-RC1 | 5.6.1 |
| `contao/contao` | Packagist | From 5.4.0-RC1 | 5.6.1 |
| `contao/core-bundle` | Packagist | From 5.0.0-RC1 | 5.3.38 |
| `contao/core-bundle` | Packagist | From 5.0.0-RC1 | 5.3.38 |
| `contao/core-bundle` | Packagist | From 5.4.0-RC1 | 5.6.1 |
| `contao/core-bundle` | Packagist | From 5.4.0-RC1 | 5.6.1 |

Products: Contao Contao.

## How do I fix CVE-2025-57757?

Upgrade contao/contao to a fixed version for your release line: 5.3.38 or 5.6.1.

## Is CVE-2025-57757 being exploited?

There is no known exploitation of CVE-2025-57757 in the wild and no public exploit code.

## Other vulnerabilities in contao

- [CVE-2022-26265](https://insights.sbomify.com/CVE-2022-26265/): Remote Code Execution in Contao Managed Edition (critical 9.8)
- [CVE-2019-11512](https://insights.sbomify.com/CVE-2019-11512/): Contao SQL injection in the file manager (critical 9.8)
- [CVE-2012-4383](https://insights.sbomify.com/CVE-2012-4383/): Contao core SQL Injection Vulnerability (high 8.8)
- [CVE-2019-19745](https://insights.sbomify.com/CVE-2019-19745/): Unrestricted file uploads in Contao (high 8.8)
- [CVE-2024-28235](https://insights.sbomify.com/CVE-2024-28235/): Contao possible cookie sharing with external domains while checking protected pages for broken links (high 8.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-57757 and fix it if it is affected.

What it is: CVE-2025-57757 is a medium-severity vulnerability in contao, published on 28 Aug 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-57757 in the wild and no public exploit code.

Affected packages and fixed versions:
- contao/contao (Packagist): affected from 5.0.0-RC1; fixed in 5.3.38
- contao/contao (Packagist): affected from 5.0.0-RC1; fixed in 5.3.38
- contao/contao (Packagist): affected from 5.4.0-RC1; fixed in 5.6.1
- contao/contao (Packagist): affected from 5.4.0-RC1; fixed in 5.6.1
- contao/core-bundle (Packagist): affected from 5.0.0-RC1; fixed in 5.3.38
- contao/core-bundle (Packagist): affected from 5.0.0-RC1; fixed in 5.3.38
- contao/core-bundle (Packagist): affected from 5.4.0-RC1; fixed in 5.6.1
- contao/core-bundle (Packagist): affected from 5.4.0-RC1; fixed in 5.6.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-57757/ (Markdown: https://insights.sbomify.com/CVE-2025-57757/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-57757
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-57757
- OSV: https://osv.dev/vulnerability/CVE-2025-57757

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-57757/
Summaries are generated and may contain mistakes; the official description above is the record.
