CVE-2025-57758 Contao has improper access control in the back end voters
Attackers can bypass access controls in the Contao CMS back end to access modules they are not authorized to view.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2025-57758?
CVE-2025-57758 is a medium-severity missing authorization vulnerability in contao, published on 28 Aug 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
Contao is an Open Source CMS. In versions starting from 5.0.0 and prior to 5.3.38 and 5.6.1, the table access voter in the back end doesn't check if a user is allowed to access the corresponding module. This issue has been patched in versions 5.3.38 and 5.6.1. A workaround involves not relying solely on the voter and additionally to check USER_CAN_ACCESS_MODULE.
Weakness: CWE-284
Which versions are affected by CVE-2025-57758?
8 open source packages ship an affected version, including contao/contao and contao/core-bundle. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
contao/contao Packagist | From 5.0.0 | 5.3.38 |
contao/contao Packagist | From 5.0.0 | 5.3.38 |
contao/contao Packagist | From 5.4.0-RC1 | 5.6.1 |
contao/contao Packagist | From 5.4.0-RC1 | 5.6.1 |
contao/core-bundle Packagist | From 5.0.0 | 5.3.38 |
contao/core-bundle Packagist | From 5.0.0 | 5.3.38 |
2 more packages
contao/core-bundle Packagist | From 5.4.0-RC1 | 5.6.1 |
contao/core-bundle Packagist | From 5.4.0-RC1 | 5.6.1 |
Products include Contao Contao.
How do I fix CVE-2025-57758?
Upgrade contao/contao to a fixed version for your release line: 5.3.38 or 5.6.1.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2025-57758 being exploited?
There is no known exploitation of CVE-2025-57758 in the wild and no public exploit code.
Other vulnerabilities in contao
- CVE-2022-26265 Remote Code Execution in Contao Managed Edition
- CVE-2019-11512 Contao SQL injection in the file manager
- CVE-2012-4383 Contao core SQL Injection Vulnerability
- CVE-2019-19745 Unrestricted file uploads in Contao
- CVE-2024-28235 Contao possible cookie sharing with external domains while checking protected pages for broken links
Sources
Also known as GHSA-7m47-r75r-cx8v.