CVE-2025-57759 Contao has improper privilege management for page and article fields
Back end users can edit page and article fields without proper permissions, allowing unauthorized data modification in Contao CMS.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2025-57759?
CVE-2025-57759 is a medium-severity missing authorization vulnerability in contao, published on 28 Aug 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
Contao is an Open Source CMS. In versions starting from 5.3.0 and prior to 5.3.38 and 5.6.1, under certain conditions, back end users may be able to edit fields of pages and articles without having the necessary permissions. This issue has been patched in versions 5.3.38 and 5.6.1. There are no workarounds.
Weakness: CWE-269
Which versions are affected by CVE-2025-57759?
8 open source packages ship an affected version, including contao/contao and contao/core-bundle. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
contao/contao Packagist | From 5.3.0 | 5.3.38 |
contao/contao Packagist | From 5.3.0 | 5.3.38 |
contao/contao Packagist | From 5.4.0-RC1 | 5.6.1 |
contao/contao Packagist | From 5.4.0-RC1 | 5.6.1 |
contao/core-bundle Packagist | From 5.3.0 | 5.3.38 |
contao/core-bundle Packagist | From 5.3.0 | 5.3.38 |
2 more packages
contao/core-bundle Packagist | From 5.4.0-RC1 | 5.6.1 |
contao/core-bundle Packagist | From 5.4.0-RC1 | 5.6.1 |
Products include Contao Contao.
How do I fix CVE-2025-57759?
Upgrade contao/contao to a fixed version for your release line: 5.3.38 or 5.6.1.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2025-57759 being exploited?
There is no known exploitation of CVE-2025-57759 in the wild and no public exploit code.
Other vulnerabilities in contao
- CVE-2022-26265 Remote Code Execution in Contao Managed Edition
- CVE-2019-11512 Contao SQL injection in the file manager
- CVE-2012-4383 Contao core SQL Injection Vulnerability
- CVE-2019-19745 Unrestricted file uploads in Contao
- CVE-2024-28235 Contao possible cookie sharing with external domains while checking protected pages for broken links
Sources
Also known as GHSA-qqfq-7cpp-hcqj.