# CVE-2025-57766: Fides's Admin UI User Password Change Does Not Invalidate Current Session

> Attackers with stolen session tokens retain access after password changes, requiring an upgrade to invalidate sessions.

- **Severity:** Low 1.7 (`CVSS:4.0/AV:N/AC:H/AT:N/PR:N/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N/E:U`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 8 Sep 2025
- **Updated:** 9 Sep 2025
- **Also known as:** GHSA-rpw8-82v9-3q87, PYSEC-2026-1348

## What is CVE-2025-57766?

CVE-2025-57766 is a low-severity vulnerability in ethyca fides, published on 8 Sep 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Fides is an open-source privacy engineering platform. Prior to version 2.69.1, admin UI user password changes in Fides do not invalidate active user sessions, creating a vulnerability chaining opportunity where attackers who have obtained session tokens through other attack vectors (such as XSS) can maintain access even after password reset. This issue is not directly exploitable on its own and requires a prerequisite vulnerability to obtain valid session tokens in the first place. Version 2.69.1 fixes the issue. No known workarounds are available.

Weakness: CWE-613 (DEPRECATED: Insufficient Session Expiration)

## Which versions are affected by CVE-2025-57766?

3 open source packages ship an affected version, including ethyca-fides. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `ethyca-fides` | PyPI | All versions | 2.69.1 |
| `ethyca-fides` | PyPI | All versions | 2.69.1 |
| `ethyca-fides` | PyPI | All versions | 2.69.1 |

Products: Ethyca Fides.

## How do I fix CVE-2025-57766?

Upgrade ethyca-fides to 2.69.1 or later.

## Is CVE-2025-57766 being exploited?

There is no known exploitation of CVE-2025-57766 in the wild and no public exploit code.

## Other vulnerabilities in ethyca fides

- [CVE-2024-45053](https://insights.sbomify.com/CVE-2024-45053/): Remote Code Execution Vulnerability via SSTI in Fides Webserver Jinja Email Templating Engine (critical 9.1)
- [CVE-2023-41319](https://insights.sbomify.com/CVE-2023-41319/): Remote Code Execution in Custom Integration Upload in Fides (high 8.8)
- [CVE-2025-57817](https://insights.sbomify.com/CVE-2025-57817/): Fides Webserver API is Vulnerable to OAuth Client Privilege Escalation (high 8.6)
- [CVE-2023-48224](https://insights.sbomify.com/CVE-2023-48224/): Cryptographically Weak Generation of One-Time Codes for Identity Verification in ethyca-fides (high 8.2)
- [CVE-2023-46124](https://insights.sbomify.com/CVE-2023-46124/): Server-Side Request Forgery Vulnerability in Custom Integration Upload (high 8.2)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-57766 and fix it if it is affected.

What it is: CVE-2025-57766 is a low-severity vulnerability in ethyca fides, published on 8 Sep 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-57766 in the wild and no public exploit code.

Affected packages and fixed versions:
- ethyca-fides (PyPI): affected all versions; fixed in 2.69.1
- ethyca-fides (PyPI): affected all versions; fixed in 2.69.1
- ethyca-fides (PyPI): affected all versions; fixed in 2.69.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-57766/ (Markdown: https://insights.sbomify.com/CVE-2025-57766/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-57766
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-57766
- OSV: https://osv.dev/vulnerability/CVE-2025-57766

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-57766/
Summaries are generated and may contain mistakes; the official description above is the record.
