CVE-2025-57767 Asterisk can crash from a specifically malformed Authorization header in an incoming SIP request
A remote attacker can crash Asterisk by sending a SIP request with a malformed Authorization header, causing a null pointer dereference.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2025-57767?
CVE-2025-57767 is a high-severity vulnerability in asterisk, published on 28 Aug 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Asterisk is an open source private branch exchange and telephony toolkit. Prior to versions 20.15.2, 21.10.2, and 22.5.2, if a SIP request is received with an Authorization header that contains a realm that wasn't in a previous 401 response's WWW-Authenticate header, or an Authorization header with an incorrect realm was received without a previous 401 response being sent, the get_authorization_header() function in res_pjsip_authenticator_digest will return a NULL. This wasn't being checked before attempting to get the digest algorithm from the header which causes a SEGV. This issue has been patched in versions 20.15.2, 21.10.2, and 22.5.2. There are no workarounds.
Weakness: CWE-253
Which versions are affected by CVE-2025-57767?
It affects 1 product.
Products include Sangoma Asterisk.
How do I fix CVE-2025-57767?
Upgrade to a fixed version.
Is CVE-2025-57767 being exploited?
There is no known exploitation of CVE-2025-57767 in the wild and no public exploit code.
Other vulnerabilities in asterisk
- CVE-2024-57520 Path traversal in n/a
- CVE-2025-47779 Using malformed From header can forge identity with ";" or NULL in name portion
- CVE-2022-37325 Memory corruption in n/a
- CVE-2025-1131 Asterisk Unsafe Shell Sourcing in safe_asterisk Leads to Local Privilege Escalation
- CVE-2025-54995 Asterisk remotely exploitable leak of RTP UDP ports and internal resources
Sources
Also known as DEBIAN-CVE-2025-57767, GHSA-64qc-9x89-rx5j, UBUNTU-CVE-2025-57767.