{"answers":{"affected":"","exploited":"There is no known exploitation of CVE-2025-57771 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2025-57771 yet. Limit exposure of the affected software until one is available.","what":"CVE-2025-57771 is a high-severity command injection vulnerability in RooCodeInc Roo-Code, published on 22 Aug 2025. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-57771 and fix it if it is affected.\n\nWhat it is: CVE-2025-57771 is a high-severity command injection vulnerability in RooCodeInc Roo-Code, published on 22 Aug 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2025-57771 in the wild and no public exploit code.\n\nAffected product: RooCodeInc Roo-Code. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-57771/ (Markdown: https://insights.sbomify.com/CVE-2025-57771/index.md)","id":"CVE-2025-57771","markdown":"https://insights.sbomify.com/CVE-2025-57771/index.md","name":"CVE-2025-57771","record":{"aliases":["GHSA-wrh9-463x-7wvv"],"analysis":{"component_type":"developer_tool","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":true,"product_category":"AI coding agent","requires_auth":"none","summary":"Attackers can execute arbitrary code via crafted prompts if auto-approved command execution is enabled in Roo-Code.","user_interaction":"not_required","vuln_class":"command_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":8.1,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-78","name":"Improper Neutralization of Special Elements used in an OS Command"}],"description":"Roo Code is an AI-powered autonomous coding agent that lives in users' editors. In versions prior to 3.25.5, Roo-Code fails to properly handle process substitution and single ampersand characters in the command parsing logic for auto-execute commands. If a user has enabled auto-approved execution for a command such as ls, an attacker who can submit crafted prompts to the agent may inject arbitrary commands to be executed alongside the intended command. Exploitation requires attacker access to submit prompts and for the user to have enabled auto-approved command execution, which is disabled by default. This vulnerability could allow an attacker to execute arbitrary code. The issue is fixed in version 3.25.5.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":false,"headline":"Roo-Code potential remote code execution via auto-execute command parsing flaw","id":"CVE-2025-57771","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"command_injection","year":"2025"},"n_packages":0,"n_references":2,"next":{"headline":"Dataease H2 JDBC RCE Bypass","id":"CVE-2025-57772"},"packages":[],"prev":{"headline":"ZITADEL user enumeration vulnerability in login UI","id":"CVE-2025-57770"},"products":["Roo-Code"],"published":"2025-08-22","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-08-22","vendors":["RooCodeInc"]},"summary":"Attackers can execute arbitrary code via crafted prompts if auto-approved command execution is enabled in Roo-Code.","url":"https://insights.sbomify.com/CVE-2025-57771/"}