# CVE-2025-57771: Roo-Code potential remote code execution via auto-execute command parsing flaw

> Attackers can execute arbitrary code via crafted prompts if auto-approved command execution is enabled in Roo-Code.

- **Severity:** High 8.1 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 22 Aug 2025
- **Updated:** 22 Aug 2025
- **Also known as:** GHSA-wrh9-463x-7wvv

## What is CVE-2025-57771?

CVE-2025-57771 is a high-severity command injection vulnerability in RooCodeInc Roo-Code, published on 22 Aug 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Roo Code is an AI-powered autonomous coding agent that lives in users' editors. In versions prior to 3.25.5, Roo-Code fails to properly handle process substitution and single ampersand characters in the command parsing logic for auto-execute commands. If a user has enabled auto-approved execution for a command such as ls, an attacker who can submit crafted prompts to the agent may inject arbitrary commands to be executed alongside the intended command. Exploitation requires attacker access to submit prompts and for the user to have enabled auto-approved command execution, which is disabled by default. This vulnerability could allow an attacker to execute arbitrary code. The issue is fixed in version 3.25.5.

Weakness: CWE-78 (Improper Neutralization of Special Elements used in an OS Command)

## Which versions are affected by CVE-2025-57771?


## How do I fix CVE-2025-57771?

No fix has been published for CVE-2025-57771 yet. Limit exposure of the affected software until one is available.

## Is CVE-2025-57771 being exploited?

There is no known exploitation of CVE-2025-57771 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-57771 and fix it if it is affected.

What it is: CVE-2025-57771 is a high-severity command injection vulnerability in RooCodeInc Roo-Code, published on 22 Aug 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-57771 in the wild and no public exploit code.

Affected product: RooCodeInc Roo-Code. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-57771/ (Markdown: https://insights.sbomify.com/CVE-2025-57771/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-57771
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-57771
- OSV: https://osv.dev/vulnerability/CVE-2025-57771

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-57771/
Summaries are generated and may contain mistakes; the official description above is the record.
