CVE-2025-57773 Dataease DB2 Aspectweaver Deserialization Arbitrary File Write Vulnerability

High 8.2 Published Updated

Attackers can exploit JNDI injection to trigger deserialization and write arbitrary files, requiring specific library versions.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
None listed

What is CVE-2025-57773?

CVE-2025-57773 is a high-severity unsafe deserialization vulnerability in Dataease Dataease, published on 25 Aug 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

DataEase is an open source business intelligence and data visualization tool. Prior to version 2.10.12, because DB2 parameters are not filtered, a JNDI injection attack can be directly launched. JNDI triggers an AspectJWeaver deserialization attack, writing to various files. This vulnerability requires commons-collections 4.x and aspectjweaver-1.9.22.jar. The vulnerability has been fixed in version 2.10.12.

Weakness: CWE-94, CWE-502

Which versions are affected by CVE-2025-57773?

It affects 1 product.

Products include Dataease Dataease.

How do I fix CVE-2025-57773?

No fix has been published for CVE-2025-57773 yet. Limit exposure of the affected software until one is available.

Upgrade, and only deserialise data from trusted sources or with an allow-list of types. More about Unsafe deserialization.

Is CVE-2025-57773 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-57773 exists.

All Dataease Dataease vulnerabilities

Sources

Also known as GHSA-7r8j-6whv-4j5p.

Is CVE-2025-57773 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free