# CVE-2025-57773: Dataease DB2 Aspectweaver Deserialization Arbitrary File Write Vulnerability

> Attackers can exploit JNDI injection to trigger deserialization and write arbitrary files, requiring specific library versions.

- **Severity:** High 8.2 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 25 Aug 2025
- **Updated:** 25 Aug 2025
- **Also known as:** GHSA-7r8j-6whv-4j5p

## What is CVE-2025-57773?

CVE-2025-57773 is a high-severity unsafe deserialization vulnerability in Dataease Dataease, published on 25 Aug 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

DataEase is an open source business intelligence and data visualization tool. Prior to version 2.10.12, because DB2 parameters are not filtered, a JNDI injection attack can be directly launched. JNDI triggers an AspectJWeaver deserialization attack, writing to various files. This vulnerability requires commons-collections 4.x and aspectjweaver-1.9.22.jar. The vulnerability has been fixed in version 2.10.12.

Weakness: CWE-94 (Improper Control of Generation of Code), CWE-502 (Deserialization of Untrusted Data)

## Which versions are affected by CVE-2025-57773?

It affects 1 product.


Products: Dataease Dataease.

## How do I fix CVE-2025-57773?

No fix has been published for CVE-2025-57773 yet. Limit exposure of the affected software until one is available.

## Is CVE-2025-57773 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-57773 exists.

## Other vulnerabilities in Dataease Dataease

- [CVE-2024-57707](https://insights.sbomify.com/CVE-2024-57707/): Code injection in n/a (critical 9.8)
- [CVE-2024-46997](https://insights.sbomify.com/CVE-2024-46997/): DataEase's H2 datasource has a remote command execution risk (critical 9.8)
- [CVE-2023-33963](https://insights.sbomify.com/CVE-2023-33963/): DataEase data source has deserialization vulnerability (critical 9.8)
- [CVE-2023-28437](https://insights.sbomify.com/CVE-2023-28437/): SQL injection vulnerability due to the keyword blacklist for defending against SQL injection will be bypassed (critical 9.8)
- [CVE-2022-39312](https://insights.sbomify.com/CVE-2022-39312/): Dataease Mysql Data Source JDBC Connection Parameters Not Verified Leads to Deserialization Vulnerability (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-57773 and fix it if it is affected.

What it is: CVE-2025-57773 is a high-severity unsafe deserialization vulnerability in Dataease Dataease, published on 25 Aug 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-57773 exists.

Affected product: Dataease Dataease. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-57773/ (Markdown: https://insights.sbomify.com/CVE-2025-57773/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-57773
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-57773
- OSV: https://osv.dev/vulnerability/CVE-2025-57773

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-57773/
Summaries are generated and may contain mistakes; the official description above is the record.
