CVE-2025-57798 Joplin has Denial of Service (DoS) via Uncontrolled Resource Allocation through Title Input

Medium 5.5 Published Updated

An attacker can cause a denial of service in Joplin by submitting excessively long note titles, leading to memory exhaustion and application crash.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Local or same network only
Victim action needed
Not needed
Fix
None listed

What is CVE-2025-57798?

CVE-2025-57798 is a medium-severity denial of service vulnerability in laurent22 joplin, published on 19 May 2026. It can only be exploited from the same machine or local network, with no action from the victim.

Official description

Joplin is an open source note-taking and to-do application that organises notes and lists into notebooks. Versions 3.6.14 and prior contain a Denial of Service (DoS) vulnerability in the title input functionality due to a lack of proper length validation. This flaw allows an attacker to cause an Out Of Memory (OOM) error and subsequent program termination by inserting an excessively long string into a note's title. This can be triggered either through direct user interface (UI) input or programmatically via the local web service API after compromising an authentication token. There are 2 primary methods of exploitation: via User Interface (UI) Input, and the Local Web Service API. A local user can directly type or paste an extremely long string into the title field when creating or editing a note Joplin runs a local web service (typically on port 41184) that allows programmatic interaction, such as creating or editing notes via HTTP API calls. If an attacker manages to exfiltrate or compromise the user's authentication token (e.g., through malware on the local system, or other local vulnerabilities), they can then send a crafted HTTP POST request to this local API. By including an excessively long string in the title parameter of this request, the application will attempt to allocate an unbounded amount of memory. This issue has been patched in version 3.7.1.

Weakness: CWE-770

Which versions are affected by CVE-2025-57798?

How do I fix CVE-2025-57798?

No fix has been published for CVE-2025-57798 yet. Limit exposure of the affected software until one is available.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2025-57798 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-57798 exists.

Sources

Also known as GHSA-6jm8-gr87-q69x.

Is CVE-2025-57798 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free