# CVE-2025-57800: Audiobookshelf vulnerable to OIDC token exfiltration and account takeover

> Attackers can exploit an open redirect in OIDC authentication to steal tokens and take over user accounts, including admin privileges.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 22 Aug 2025
- **Updated:** 22 Aug 2025
- **Also known as:** GHSA-vpc2-w73p-39px

## What is CVE-2025-57800?

CVE-2025-57800 is a high-severity vulnerability in advplyr audiobookshelf, published on 22 Aug 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Audiobookshelf is an open-source self-hosted audiobook server. In versions 2.6.0 through 2.26.3, the application does not properly restrict redirect callback URLs during OIDC authentication. An attacker can craft a login link that causes Audiobookshelf to store an arbitrary callback in a cookie, which is later used to redirect the user after authentication. The server then issues a 302 redirect to the attacker-controlled URL, appending sensitive OIDC tokens as query parameters. This allows an attacker to obtain the victim's tokens and perform full account takeover, including creating persistent admin users if the victim is an administrator. Tokens are further leaked via browser history, Referer headers, and server logs. This vulnerability impacts all Audiobookshelf deployments using OIDC; no IdP misconfiguration is required. The issue is fixed in version 2.28.0. No known workarounds exist.

Weakness: CWE-601 (URL Redirection to Untrusted Site), CWE-598 (Use of HTTP Request With Sensitive Query String), CWE-523 (Unprotected Transport of Credentials)

## Which versions are affected by CVE-2025-57800?

It affects 1 product.


Products: Audiobookshelf Audiobookshelf.

## How do I fix CVE-2025-57800?

No fix has been published for CVE-2025-57800 yet. Limit exposure of the affected software until one is available.

## Is CVE-2025-57800 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-57800 exists.

## Other vulnerabilities in advplyr audiobookshelf

- [CVE-2025-25205](https://insights.sbomify.com/CVE-2025-25205/): Remote Authentication-Bypass can lead to server crash or limited information disclosure due to faulty pattern matching (high 8.2)
- [CVE-2023-47619](https://insights.sbomify.com/CVE-2023-47619/): Audiobookshelf Server-Side Request Forgery and Arbitrary File Read Vulnerability (high 8.1)
- [CVE-2023-47624](https://insights.sbomify.com/CVE-2023-47624/): Audiobookshelf Arbitrary File Read Vulnerability (high 7.5)
- [CVE-2025-46338](https://insights.sbomify.com/CVE-2025-46338/): Audiobookshelf Vulnerable to Cross-Site-Scripting Reflected via POST Request in /api/upload (medium 6.9)
- [CVE-2024-43797](https://insights.sbomify.com/CVE-2024-43797/): Path Traversal in audiobookshelf (medium 6.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-57800 and fix it if it is affected.

What it is: CVE-2025-57800 is a high-severity vulnerability in advplyr audiobookshelf, published on 22 Aug 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-57800 exists.

Affected product: advplyr audiobookshelf. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-57800/ (Markdown: https://insights.sbomify.com/CVE-2025-57800/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-57800
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-57800
- OSV: https://osv.dev/vulnerability/CVE-2025-57800

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-57800/
Summaries are generated and may contain mistakes; the official description above is the record.
