# CVE-2025-57801: gnark is vulnerable to signature malleability in EdDSA and ECDSA due to missing scalar checks

> Attackers can exploit signature malleability in gnark to bypass anti-replay checks, potentially enabling double spending in dependent protocols.

- **Severity:** High 8.6 (`CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:L/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 22 Aug 2025
- **Updated:** 22 Aug 2025
- **Also known as:** GHSA-95v9-hv42-pwrj, GO-2025-3912

## What is CVE-2025-57801?

CVE-2025-57801 is a high-severity vulnerability in Consensys gnark, published on 22 Aug 2025. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

gnark is a zero-knowledge proof system framework. In versions prior to 0.14.0, the Verify function in eddsa.go and ecdsa.go used the S value from a signature without asserting that 0 ≤ S < order, leading to a signature malleability vulnerability. Because gnark’s native EdDSA and ECDSA circuits lack essential constraints, multiple distinct witnesses can satisfy the same public inputs. In protocols where nullifiers or anti-replay checks are derived from R and S, this enables signature malleability and may allow double spending. This issue has been addressed in version 0.14.0.

Weakness: CWE-347 (Improper Verification of Cryptographic Signature)

## Which versions are affected by CVE-2025-57801?

3 open source packages ship an affected version, including github.com/consensys/gnark. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/consensys/gnark` | Go | All versions | 0.14.0 |
| `github.com/consensys/gnark` | Go | All versions | 0.14.0 |
| `github.com/consensys/gnark` | Go | All versions | 0.14.0 |

Products: Consensys Gnark.

## How do I fix CVE-2025-57801?

Upgrade github.com/consensys/gnark to 0.14.0 or later.

## Is CVE-2025-57801 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-57801 exists.

## Other vulnerabilities in Consensys gnark

- [CVE-2025-58157](https://insights.sbomify.com/CVE-2025-58157/): gnark affected by denial of service when computing scalar multiplication using fake-GLV algorithm (high 7.5)
- [CVE-2023-44378](https://insights.sbomify.com/CVE-2023-44378/): gnark vulnerable to unsoundness in variable comparison/non-unique binary decomposition (high 7.1)
- [CVE-2024-50354](https://insights.sbomify.com/CVE-2024-50354/): Out-of-memory during deserialization with crafted inputs (medium 5.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-57801 and fix it if it is affected.

What it is: CVE-2025-57801 is a high-severity vulnerability in Consensys gnark, published on 22 Aug 2025. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-57801 exists.

Affected packages and fixed versions:
- github.com/consensys/gnark (Go): affected all versions; fixed in 0.14.0
- github.com/consensys/gnark (Go): affected all versions; fixed in 0.14.0
- github.com/consensys/gnark (Go): affected all versions; fixed in 0.14.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-57801/ (Markdown: https://insights.sbomify.com/CVE-2025-57801/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-57801
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-57801
- OSV: https://osv.dev/vulnerability/CVE-2025-57801

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-57801/
Summaries are generated and may contain mistakes; the official description above is the record.
