# CVE-2025-57803: ImageMagick (WriteBMPImage): 32-bit integer overflow when writing BMP scanline stride → heap buffer overflow

> A 32-bit integer overflow in ImageMagick's BMP encoder causes a heap buffer overflow, allowing attackers to execute arbitrary code via crafted images.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 26 Aug 2025
- **Updated:** 26 Feb 2026
- **Also known as:** CLSA-2025-1759856402, CLSA-2025-1760019012, CLSA-2025-1760023801, CLSA-2026-1776170814, CLSA-2026-1776171379, CLSA-2026-1776171616, DEBIAN-CVE-2025-57803, GHSA-mxvv-97wh-cfmm, JLSEC-2026-925, MINI-f5h4-gj77-9cj5, RHSA-2025:16313, UBUNTU-CVE-2025-57803

## What is CVE-2025-57803?

CVE-2025-57803 is a high-severity vulnerability in Imagemagick Imagemagick, published on 26 Aug 2025. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

ImageMagick is free and open-source software used for editing and manipulating digital images. Prior to versions 6.9.13-28 and 7.1.2-2 for ImageMagick's 32-bit build, a 32-bit integer overflow in the BMP encoder’s scanline-stride computation collapses bytes_per_line (stride) to a tiny value while the per-row writer still emits 3 × width bytes for 24-bpp images. The row base pointer advances using the (overflowed) stride, so the first row immediately writes past its slot and into adjacent heap memory with attacker-controlled bytes. This is a classic, powerful primitive for heap corruption in common auto-convert pipelines. This issue has been patched in versions 6.9.13-28 and 7.1.2-2.

Weakness: CWE-190 (Integer Overflow or Wraparound), CWE-122 (Heap-based Buffer Overflow)

## Which versions are affected by CVE-2025-57803?

12 open source packages ship an affected version, including Magick.NET-Q16-AnyCPU, Magick.NET-Q16-HDRI-AnyCPU and Magick.NET-Q16-HDRI-x86. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `Magick.NET-Q16-AnyCPU` | NuGet | All versions | 14.8.1 |
| `Magick.NET-Q16-AnyCPU` | NuGet | All versions | 14.8.1 |
| `Magick.NET-Q16-HDRI-AnyCPU` | NuGet | All versions | 14.8.1 |
| `Magick.NET-Q16-HDRI-AnyCPU` | NuGet | All versions | 14.8.1 |
| `Magick.NET-Q16-HDRI-x86` | NuGet | All versions | 14.8.1 |
| `Magick.NET-Q16-HDRI-x86` | NuGet | All versions | 14.8.1 |
| `Magick.NET-Q16-x86` | NuGet | All versions | 14.8.1 |
| `Magick.NET-Q16-x86` | NuGet | All versions | 14.8.1 |
| `Magick.NET-Q8-AnyCPU` | NuGet | All versions | 14.8.1 |
| `Magick.NET-Q8-AnyCPU` | NuGet | All versions | 14.8.1 |
| `Magick.NET-Q8-x86` | NuGet | All versions | 14.8.1 |
| `Magick.NET-Q8-x86` | NuGet | All versions | 14.8.1 |
| `ImageMagick` | Red Hat:rhel_els:7 | All versions | 0:6.9.10.68-9.el7_9 |
| `ImageMagick-c++` | Red Hat:rhel_els:7 | All versions | 0:6.9.10.68-9.el7_9 |
| `ImageMagick-c++-devel` | Red Hat:rhel_els:7 | All versions | 0:6.9.10.68-9.el7_9 |
| `ImageMagick-debuginfo` | Red Hat:rhel_els:7 | All versions | 0:6.9.10.68-9.el7_9 |
| `ImageMagick-devel` | Red Hat:rhel_els:7 | All versions | 0:6.9.10.68-9.el7_9 |
| `ImageMagick-doc` | Red Hat:rhel_els:7 | All versions | 0:6.9.10.68-9.el7_9 |
| `ImageMagick-perl` | Red Hat:rhel_els:7 | All versions | 0:6.9.10.68-9.el7_9 |

Products: Imagemagick Imagemagick.

## How do I fix CVE-2025-57803?

Upgrade Magick.NET-Q16-AnyCPU to 14.8.1 or later.

## Is CVE-2025-57803 being exploited?

There is no known exploitation of CVE-2025-57803 in the wild and no public exploit code.

## Other vulnerabilities in Imagemagick Imagemagick

- [CVE-2019-19952](https://insights.sbomify.com/CVE-2019-19952/): Use after free in n/a (critical 9.8)
- [CVE-2018-16328](https://insights.sbomify.com/CVE-2018-16328/): Null dereference in n/a (critical 9.8)
- [CVE-2018-16329](https://insights.sbomify.com/CVE-2018-16329/): Null dereference in n/a (critical 9.8)
- [CVE-2017-18210](https://insights.sbomify.com/CVE-2017-18210/): Null dereference in n/a (critical 9.8)
- [CVE-2017-14138](https://insights.sbomify.com/CVE-2017-14138/): Denial of service in n/a (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-57803 and fix it if it is affected.

What it is: CVE-2025-57803 is a high-severity vulnerability in Imagemagick Imagemagick, published on 26 Aug 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-57803 in the wild and no public exploit code.

Affected packages and fixed versions:
- Magick.NET-Q16-AnyCPU (NuGet): affected all versions; fixed in 14.8.1
- Magick.NET-Q16-AnyCPU (NuGet): affected all versions; fixed in 14.8.1
- Magick.NET-Q16-HDRI-AnyCPU (NuGet): affected all versions; fixed in 14.8.1
- Magick.NET-Q16-HDRI-AnyCPU (NuGet): affected all versions; fixed in 14.8.1
- Magick.NET-Q16-HDRI-x86 (NuGet): affected all versions; fixed in 14.8.1
- Magick.NET-Q16-HDRI-x86 (NuGet): affected all versions; fixed in 14.8.1
- Magick.NET-Q16-x86 (NuGet): affected all versions; fixed in 14.8.1
- Magick.NET-Q16-x86 (NuGet): affected all versions; fixed in 14.8.1
- Magick.NET-Q8-AnyCPU (NuGet): affected all versions; fixed in 14.8.1
- Magick.NET-Q8-AnyCPU (NuGet): affected all versions; fixed in 14.8.1
- Magick.NET-Q8-x86 (NuGet): affected all versions; fixed in 14.8.1
- Magick.NET-Q8-x86 (NuGet): affected all versions; fixed in 14.8.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-57803/ (Markdown: https://insights.sbomify.com/CVE-2025-57803/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-57803
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-57803
- OSV: https://osv.dev/vulnerability/CVE-2025-57803

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-57803/
Summaries are generated and may contain mistakes; the official description above is the record.
