CVE-2025-57804 h2 allows HTTP Request Smuggling due to illegal characters in headers
- Exploited in the wild
- Not known
- Fix
- Available
What is CVE-2025-57804?
CVE-2025-57804 is a medium-severity vulnerability in python-hyper h2, published on 25 Aug 2025.
Official description
h2 is a pure-Python implementation of a HTTP/2 protocol stack. Prior to version 4.3.0, an HTTP/2 request splitting vulnerability allows attackers to perform request smuggling attacks by injecting CRLF characters into headers. This occurs when servers downgrade HTTP/2 requests to HTTP/1.1 without properly validating header names/values, enabling attackers to manipulate request boundaries and bypass security controls. This issue has been patched in version 4.3.0.
Weakness: CWE-93
Which versions are affected by CVE-2025-57804?
3 open source packages ship an affected version, including h2.
| Package | Affected | Fixed in |
|---|---|---|
h2 PyPI | All versions | 4.3.0 |
h2 PyPI | All versions | 4.3.0 |
h2 PyPI | All versions | 4.3.0 |
Linux distribution packages (9)
python-h2 SUSE:Linux Enterprise Module for Python 3 15 SP6 | All versions | 4.1.0-150400.8.6.1 |
python-h2 SUSE:Linux Enterprise Module for Python 3 15 SP7 | All versions | 4.1.0-150400.8.6.1 |
python-h2 SUSE:Linux Enterprise Module for Server Applications 15 SP6 | All versions | 3.2.0-150200.3.5.1 |
python-h2 SUSE:Linux Enterprise Module for Server Applications 15 SP7 | All versions | 3.2.0-150200.3.5.1 |
python-h2 SUSE:Linux Enterprise Server 16.0 | All versions | 4.2.0-160000.3.1 |
python-h2 SUSE:Linux Enterprise Server for SAP applications 16.0 | All versions | 4.2.0-160000.3.1 |
python-h2 openSUSE:Leap 15.6 | All versions | 4.1.0-150400.8.6.1 |
python-h2 openSUSE:Leap 16.0 | All versions | 4.2.0-160000.3.1 |
python-h2 openSUSE:Tumbleweed | All versions | 4.3.0-1.1 |
How do I fix CVE-2025-57804?
Upgrade h2 to 4.3.0 or later.
Is CVE-2025-57804 being exploited?
There is no known exploitation of CVE-2025-57804 in the wild and no public exploit code.
Sources
Also known as BELL-CVE-2025-57804, CLEANSTART-2026-HH25957, CLEANSTART-2026-HI28272, DEBIAN-CVE-2025-57804, DLA-4290-1, ECHO-a060-6ee9-114c and 10 more.