# CVE-2025-57804: h2 allows HTTP Request Smuggling due to illegal characters in headers


- **Severity:** Medium 6.9 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:N/SC:N/SI:L/SA:N`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 25 Aug 2025
- **Updated:** 3 Nov 2025
- **Also known as:** BELL-CVE-2025-57804, CLEANSTART-2026-HH25957, CLEANSTART-2026-HI28272, DEBIAN-CVE-2025-57804, DLA-4290-1, ECHO-a060-6ee9-114c, GHSA-847f-9342-265h, OESA-2025-2250, PYSEC-2026-1435, ROOT-APP-PYPI-CVE-2025-57804, SUSE-SU-2025:03199-1, SUSE-SU-2025:03273-1, SUSE-SU-2026:20187-1, UBUNTU-CVE-2025-57804, openSUSE-SU-2025:15496-1, openSUSE-SU-2026:20122-1

## What is CVE-2025-57804?

CVE-2025-57804 is a medium-severity vulnerability in python-hyper h2, published on 25 Aug 2025. 

### Official description

h2 is a pure-Python implementation of a HTTP/2 protocol stack. Prior to version 4.3.0, an HTTP/2 request splitting vulnerability allows attackers to perform request smuggling attacks by injecting CRLF characters into headers. This occurs when servers downgrade HTTP/2 requests to HTTP/1.1 without properly validating header names/values, enabling attackers to manipulate request boundaries and bypass security controls. This issue has been patched in version 4.3.0.

Weakness: CWE-93 (Improper Neutralization of CRLF Sequences)

## Which versions are affected by CVE-2025-57804?

3 open source packages ship an affected version, including h2.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `h2` | PyPI | All versions | 4.3.0 |
| `h2` | PyPI | All versions | 4.3.0 |
| `h2` | PyPI | All versions | 4.3.0 |
| `python-h2` | SUSE:Linux Enterprise Module for Python 3 15 SP6 | All versions | 4.1.0-150400.8.6.1 |
| `python-h2` | SUSE:Linux Enterprise Module for Python 3 15 SP7 | All versions | 4.1.0-150400.8.6.1 |
| `python-h2` | SUSE:Linux Enterprise Module for Server Applications 15 SP6 | All versions | 3.2.0-150200.3.5.1 |
| `python-h2` | SUSE:Linux Enterprise Module for Server Applications 15 SP7 | All versions | 3.2.0-150200.3.5.1 |
| `python-h2` | SUSE:Linux Enterprise Server 16.0 | All versions | 4.2.0-160000.3.1 |
| `python-h2` | SUSE:Linux Enterprise Server for SAP applications 16.0 | All versions | 4.2.0-160000.3.1 |
| `python-h2` | openSUSE:Leap 15.6 | All versions | 4.1.0-150400.8.6.1 |
| `python-h2` | openSUSE:Leap 16.0 | All versions | 4.2.0-160000.3.1 |
| `python-h2` | openSUSE:Tumbleweed | All versions | 4.3.0-1.1 |

## How do I fix CVE-2025-57804?

Upgrade h2 to 4.3.0 or later.

## Is CVE-2025-57804 being exploited?

There is no known exploitation of CVE-2025-57804 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-57804 and fix it if it is affected.

What it is: CVE-2025-57804 is a medium-severity vulnerability in python-hyper h2, published on 25 Aug 2025. 
Exploitation: There is no known exploitation of CVE-2025-57804 in the wild and no public exploit code.

Affected packages and fixed versions:
- h2 (PyPI): affected all versions; fixed in 4.3.0
- h2 (PyPI): affected all versions; fixed in 4.3.0
- h2 (PyPI): affected all versions; fixed in 4.3.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-57804/ (Markdown: https://insights.sbomify.com/CVE-2025-57804/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-57804
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-57804
- OSV: https://osv.dev/vulnerability/CVE-2025-57804

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-57804/
Summaries are generated and may contain mistakes; the official description above is the record.
