# CVE-2025-57806: Local Deep Research's API keys are stored in plain text

> Attackers with filesystem access can read plaintext API keys from the local database, exposing sensitive credentials to unauthorized users.

- **Severity:** Medium 6.9 (`CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 3 Sep 2025
- **Updated:** 3 Sep 2025
- **Also known as:** GHSA-4h8c-qrcq-cv5c

## What is CVE-2025-57806?

CVE-2025-57806 is a medium-severity vulnerability in LearningCircuit local-deep-research, published on 3 Sep 2025. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

Local Deep Research is an AI-powered research assistant for deep, iterative research. Versions 0.2.0 through 0.6.7 stored confidential information, including API keys, in a local SQLite database without encryption. This behavior was not clearly documented outside of the database architecture page. Users were not given the ability to configure the database location, allowing anyone with access to the container or host filesystem to retrieve sensitive data in plaintext by accessing the .db file. This is fixed in version 1.0.0.

Weakness: CWE-522 (Insufficiently Protected Credentials), CWE-312 (Cleartext Storage of Sensitive Information)

## Which versions are affected by CVE-2025-57806?


## How do I fix CVE-2025-57806?

No fix has been published for CVE-2025-57806 yet. Limit exposure of the affected software until one is available.

## Is CVE-2025-57806 being exploited?

There is no known exploitation of CVE-2025-57806 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-57806 and fix it if it is affected.

What it is: CVE-2025-57806 is a medium-severity vulnerability in LearningCircuit local-deep-research, published on 3 Sep 2025. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-57806 in the wild and no public exploit code.

Affected product: LearningCircuit local-deep-research. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-57806/ (Markdown: https://insights.sbomify.com/CVE-2025-57806/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-57806
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-57806
- OSV: https://osv.dev/vulnerability/CVE-2025-57806

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-57806/
Summaries are generated and may contain mistakes; the official description above is the record.
