CVE-2025-57807 ImageMagick BlobStream Forward-Seek Under-Allocation
A heap buffer overflow in ImageMagick allows attackers to execute arbitrary code via crafted image files due to incorrect memory allocation during stream seeking.
- Exploited in the wild
- Not known
- Login needed
- An administrator
- Attackable
- Local or same network only
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2025-57807?
CVE-2025-57807 is a low-severity memory corruption vulnerability in Imagemagick Imagemagick, published on 5 Sep 2025. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Official description
ImageMagick is free and open-source software used for editing and manipulating digital images. ImageMagick versions lower than 14.8.2 include insecure functions: SeekBlob(), which permits advancing the stream offset beyond the current end without increasing capacity, and WriteBlob(), which then expands by quantum + length (amortized) instead of offset + length, and copies to data + offset. When offset ≫ extent, the copy targets memory beyond the allocation, producing a deterministic heap write on 64-bit builds. No 2⁶⁴ arithmetic wrap, external delegates, or policy settings are required. This is fixed in version 14.8.2.
Which versions are affected by CVE-2025-57807?
24 open source packages ship an affected version, including Magick.NET-Q16-HDRI-OpenMP-arm64, Magick.NET-Q16-HDRI-OpenMP-x64 and Magick.NET-Q16-HDRI-arm64. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
Magick.NET-Q16-HDRI-OpenMP-arm64 NuGet | All versions | 14.8.2 |
Magick.NET-Q16-HDRI-OpenMP-arm64 NuGet | All versions | 14.8.2 |
Magick.NET-Q16-HDRI-OpenMP-x64 NuGet | All versions | 14.8.2 |
Magick.NET-Q16-HDRI-OpenMP-x64 NuGet | All versions | 14.8.2 |
Magick.NET-Q16-HDRI-arm64 NuGet | All versions | 14.8.2 |
Magick.NET-Q16-HDRI-arm64 NuGet | All versions | 14.8.2 |
18 more packages
Magick.NET-Q16-HDRI-x64 NuGet | All versions | 14.8.2 |
Magick.NET-Q16-HDRI-x64 NuGet | All versions | 14.8.2 |
Magick.NET-Q16-OpenMP-arm64 NuGet | All versions | 14.8.2 |
Magick.NET-Q16-OpenMP-arm64 NuGet | All versions | 14.8.2 |
Magick.NET-Q16-OpenMP-x64 NuGet | All versions | 14.8.2 |
Magick.NET-Q16-OpenMP-x64 NuGet | All versions | 14.8.2 |
Magick.NET-Q16-arm64 NuGet | All versions | 14.8.2 |
Magick.NET-Q16-arm64 NuGet | All versions | 14.8.2 |
Magick.NET-Q16-x64 NuGet | All versions | 14.8.2 |
Magick.NET-Q16-x64 NuGet | All versions | 14.8.2 |
Magick.NET-Q8-OpenMP-arm64 NuGet | All versions | 14.8.2 |
Magick.NET-Q8-OpenMP-arm64 NuGet | All versions | 14.8.2 |
Magick.NET-Q8-OpenMP-x64 NuGet | All versions | 14.8.2 |
Magick.NET-Q8-OpenMP-x64 NuGet | All versions | 14.8.2 |
Magick.NET-Q8-arm64 NuGet | All versions | 14.8.2 |
Magick.NET-Q8-arm64 NuGet | All versions | 14.8.2 |
Magick.NET-Q8-x64 NuGet | All versions | 14.8.2 |
Magick.NET-Q8-x64 NuGet | All versions | 14.8.2 |
Linux distribution packages (8)
ImageMagick SUSE:Linux Enterprise Module for Desktop Applications 15 SP6 | All versions | 7.1.0.9-150400.6.43.1 |
ImageMagick SUSE:Linux Enterprise Module for Desktop Applications 15 SP6 | All versions | 7.1.1.21-150600.3.23.1 |
ImageMagick SUSE:Linux Enterprise Module for Desktop Applications 15 SP7 | All versions | 7.1.0.9-150400.6.43.1 |
ImageMagick SUSE:Linux Enterprise Module for Desktop Applications 15 SP7 | All versions | 7.1.1.43-150700.3.16.1 |
ImageMagick SUSE:Linux Enterprise Module for Development Tools 15 SP6 | All versions | 7.1.1.21-150600.3.23.1 |
ImageMagick SUSE:Linux Enterprise Module for Development Tools 15 SP7 | All versions | 7.1.1.43-150700.3.16.1 |
ImageMagick openSUSE:Leap 15.6 | All versions | 7.1.1.21-150600.3.23.1 |
ImageMagick openSUSE:Tumbleweed | All versions | 7.1.2.3-1.1 |
Products include Imagemagick Imagemagick.
How do I fix CVE-2025-57807?
Upgrade Magick.NET-Q16-HDRI-OpenMP-arm64 to 14.8.2 or later.
Upgrade to the fixed version. Memory-safe languages, compiler hardening and fuzzing prevent most new cases. More about Memory corruption.
Is CVE-2025-57807 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-57807 exists.
Other vulnerabilities in Imagemagick Imagemagick
Sources
Also known as CLSA-2025-1758635329, CLSA-2025-1758704282, CLSA-2025-1758705954, CLSA-2026-1775682890, CLSA-2026-1775683048, CLSA-2026-1775683193 and 14 more.