# CVE-2025-57814: request-filtering-agent SSRF Bypass via HTTPS Requests

> Attackers can bypass SSRF protections to access internal localhost services via HTTPS requests in the request-filtering-agent library.

- **Severity:** Medium 5.5 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N/E:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 25 Aug 2025
- **Updated:** 26 Aug 2025
- **Also known as:** GHSA-pw25-c82r-75mm

## What is CVE-2025-57814?

CVE-2025-57814 is a medium-severity server-side request forgery vulnerability in azu request-filtering-agent, published on 25 Aug 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

request-filtering-agent is an http(s).Agent implementation that blocks requests to Private/Reserved IP addresses. Versions 1.x.x and earlier contain a vulnerability where HTTPS requests to 127.0.0.1 bypass IP address filtering, while HTTP requests are correctly blocked. This allows attackers to potentially access internal HTTPS services running on localhost, bypassing the library's SSRF protection. The vulnerability is particularly dangerous when the application accepts user-controlled URLs and internal services are only protected by network-level restrictions. This vulnerability has been fixed in request-filtering-agent version 2.0.0. Users should upgrade to version 2.0.0 or later.

Weakness: CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2025-57814?

2 open source packages ship an affected version, including request-filtering-agent.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `request-filtering-agent` | npm | All versions | 2.0.0 |
| `request-filtering-agent` | npm | All versions | 2.0.0 |

## How do I fix CVE-2025-57814?

Upgrade request-filtering-agent to 2.0.0 or later.

## Is CVE-2025-57814 being exploited?

There is no known exploitation of CVE-2025-57814 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-57814 and fix it if it is affected.

What it is: CVE-2025-57814 is a medium-severity server-side request forgery vulnerability in azu request-filtering-agent, published on 25 Aug 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-57814 in the wild and no public exploit code.

Affected packages and fixed versions:
- request-filtering-agent (npm): affected all versions; fixed in 2.0.0
- request-filtering-agent (npm): affected all versions; fixed in 2.0.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-57814/ (Markdown: https://insights.sbomify.com/CVE-2025-57814/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-57814
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-57814
- OSV: https://osv.dev/vulnerability/CVE-2025-57814

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-57814/
Summaries are generated and may contain mistakes; the official description above is the record.
