{"answers":{"affected":"3 open source packages ship an affected version, including ethyca-fides. It affects 1 product.","exploited":"There is no known exploitation of CVE-2025-57815 in the wild and no public exploit code.","fix":"Upgrade ethyca-fides to 2.69.1 or later.","what":"CVE-2025-57815 is a low-severity authentication bypass vulnerability in ethyca fides, published on 8 Sep 2025. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-57815 and fix it if it is affected.\n\nWhat it is: CVE-2025-57815 is a low-severity authentication bypass vulnerability in ethyca fides, published on 8 Sep 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2025-57815 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- ethyca-fides (PyPI): affected all versions; fixed in 2.69.1\n- ethyca-fides (PyPI): affected all versions; fixed in 2.69.1\n- ethyca-fides (PyPI): affected all versions; fixed in 2.69.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-57815/ (Markdown: https://insights.sbomify.com/CVE-2025-57815/index.md)","id":"CVE-2025-57815","markdown":"https://insights.sbomify.com/CVE-2025-57815/index.md","name":"CVE-2025-57815","record":{"aliases":["GHSA-7q62-r88r-j5gw","PYSEC-2026-1335"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"Privacy engineering platform","requires_auth":"none","summary":"Attackers can perform brute-force credential stuffing on Fides login endpoints due to missing anti-automation controls, risking account takeover.","user_interaction":"not_required","vuln_class":"auth_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"fides","vendor":"ethyca"}],"cvss":{"score":1.7,"severity":"low","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N/E:U","version":"4.0"},"cwes":[{"id":"CWE-307","name":"Improper Restriction of Excessive Authentication Attempts"}],"description":"Fides is an open-source privacy engineering platform. Prior to version 2.69.1, the Fides Admin UI login endpoint relies on a general IP-based rate limit for all API traffic and lacks specific anti-automation controls designed to protect against brute-force attacks. This could allow attackers to conduct credential testing attacks, such as credential stuffing or password spraying, which poses a risk to accounts with weak or previously compromised passwords. Version 2.69.1 fixes the issue. For organizations with commercial Fides Enterprise licenses, configuring Single Sign-On (SSO) through an OIDC provider (like Azure, Google, or Okta) is an effective workaround. When OIDC SSO is enabled, username/password authentication can be disabled entirely, which eliminates this attack vector. This functionality is not available for Fides Open Source users.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Fides Lacks Brute-Force Protections on Authentication Endpoints","id":"CVE-2025-57815","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"auth_bypass","year":"2025"},"n_packages":3,"n_references":3,"next":{"headline":"Fides Webserver API Rate Limiting Vulnerability in Proxied Environments","id":"CVE-2025-57816"},"packages":[{"ecosystem":"PyPI","fixed":["2.69.1"],"introduced":["0"],"last_affected":[],"package":"ethyca-fides","purl":null,"source":"GHSA-7q62-r88r-j5gw"},{"ecosystem":"PyPI","fixed":["2.69.1"],"introduced":["0"],"last_affected":[],"package":"ethyca-fides","purl":"pkg:pypi/ethyca-fides","source":"GHSA-7q62-r88r-j5gw"},{"ecosystem":"PyPI","fixed":["2.69.1"],"introduced":["0"],"last_affected":[],"package":"ethyca-fides","purl":"pkg:pypi/ethyca-fides","source":"PYSEC-2026-1335"}],"prev":{"headline":"request-filtering-agent SSRF Bypass via HTTPS Requests","id":"CVE-2025-57814"},"products":["fides"],"published":"2025-09-08","related":[{"cvss_score":9.1,"headline":"Remote Code Execution Vulnerability via SSTI in Fides Webserver Jinja Email Templating Engine","id":"CVE-2024-45053","kev_date_added":null,"published":"2024-09-04"},{"cvss_score":8.8,"headline":"Remote Code Execution in Custom Integration Upload in Fides","id":"CVE-2023-41319","kev_date_added":null,"published":"2023-09-06"},{"cvss_score":8.6,"headline":"Fides Webserver API is Vulnerable to OAuth Client Privilege Escalation","id":"CVE-2025-57817","kev_date_added":null,"published":"2025-09-08"},{"cvss_score":8.2,"headline":"Cryptographically Weak Generation of One-Time Codes for Identity Verification in ethyca-fides","id":"CVE-2023-48224","kev_date_added":null,"published":"2023-11-15"},{"cvss_score":8.2,"headline":"Server-Side Request Forgery Vulnerability in Custom Integration Upload","id":"CVE-2023-46124","kev_date_added":null,"published":"2023-10-24"},{"cvss_score":7.5,"headline":"Fides vulnerable to Path Traversal in Webserver API","id":"CVE-2023-36827","kev_date_added":null,"published":"2023-07-05"},{"cvss_score":6.5,"headline":"Sensitive Data Disclosure Vulnerability in Connection Configuration Endpoints in Fides","id":"CVE-2024-35189","kev_date_added":null,"published":"2024-05-30"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-09-09","vendors":["ethyca"]},"summary":"Attackers can perform brute-force credential stuffing on Fides login endpoints due to missing anti-automation controls, risking account takeover.","url":"https://insights.sbomify.com/CVE-2025-57815/"}