# CVE-2025-57816: Fides Webserver API Rate Limiting Vulnerability in Proxied Environments

> Attackers can bypass IP-based rate limits in proxied environments, potentially causing denial of service against the Fides Webserver API.

- **Severity:** Medium 6.3 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 8 Sep 2025
- **Updated:** 9 Sep 2025
- **Also known as:** GHSA-fq34-xw6c-fphf, PYSEC-2026-1341

## What is CVE-2025-57816?

CVE-2025-57816 is a medium-severity vulnerability in ethyca fides, published on 8 Sep 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Fides is an open-source privacy engineering platform. Prior to version 2.69.1, the Fides Webserver API's built-in IP-based rate limiting is ineffective in environments with CDNs, proxies or load balancers. The system incorrectly applies rate limits based on directly connected infrastructure IPs rather than client IPs, and stores counters in-memory rather than in a shared store. This allows attackers to bypass intended rate limits and potentially cause denial of service. This vulnerability only affects deployments relying on Fides's built-in rate limiting for protection. Deployments using external rate limiting solutions (WAFs, API gateways, etc.) are not affected. Version 2.69.1 fixes the issue. There are no application-level workarounds. However, rate limiting may instead be implemented externally at the infrastructure level using a WAF, API Gateway, or similar technology.

Weakness: CWE-799 (Improper Control of Interaction Frequency)

## Which versions are affected by CVE-2025-57816?

3 open source packages ship an affected version, including ethyca-fides. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `ethyca-fides` | PyPI | All versions | 2.69.1 |
| `ethyca-fides` | PyPI | All versions | 2.69.1 |
| `ethyca-fides` | PyPI | All versions | 2.69.1 |

Products: Ethyca Fides.

## How do I fix CVE-2025-57816?

Upgrade ethyca-fides to 2.69.1 or later.

## Is CVE-2025-57816 being exploited?

There is no known exploitation of CVE-2025-57816 in the wild and no public exploit code.

## Other vulnerabilities in ethyca fides

- [CVE-2024-45053](https://insights.sbomify.com/CVE-2024-45053/): Remote Code Execution Vulnerability via SSTI in Fides Webserver Jinja Email Templating Engine (critical 9.1)
- [CVE-2023-41319](https://insights.sbomify.com/CVE-2023-41319/): Remote Code Execution in Custom Integration Upload in Fides (high 8.8)
- [CVE-2025-57817](https://insights.sbomify.com/CVE-2025-57817/): Fides Webserver API is Vulnerable to OAuth Client Privilege Escalation (high 8.6)
- [CVE-2023-48224](https://insights.sbomify.com/CVE-2023-48224/): Cryptographically Weak Generation of One-Time Codes for Identity Verification in ethyca-fides (high 8.2)
- [CVE-2023-46124](https://insights.sbomify.com/CVE-2023-46124/): Server-Side Request Forgery Vulnerability in Custom Integration Upload (high 8.2)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-57816 and fix it if it is affected.

What it is: CVE-2025-57816 is a medium-severity vulnerability in ethyca fides, published on 8 Sep 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-57816 in the wild and no public exploit code.

Affected packages and fixed versions:
- ethyca-fides (PyPI): affected all versions; fixed in 2.69.1
- ethyca-fides (PyPI): affected all versions; fixed in 2.69.1
- ethyca-fides (PyPI): affected all versions; fixed in 2.69.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-57816/ (Markdown: https://insights.sbomify.com/CVE-2025-57816/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-57816
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-57816
- OSV: https://osv.dev/vulnerability/CVE-2025-57816

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-57816/
Summaries are generated and may contain mistakes; the official description above is the record.
