# CVE-2025-57817: Fides Webserver API is Vulnerable to OAuth Client Privilege Escalation

> Privileged users can escalate to owner-level via improper scope authorization in OAuth client endpoints, requiring an upgrade to fix.

- **Severity:** High 8.6 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:H/VI:H/VA:L/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 8 Sep 2025
- **Updated:** 9 Sep 2025
- **Also known as:** GHSA-hjfh-p8f5-24wr, PYSEC-2026-1343

## What is CVE-2025-57817?

CVE-2025-57817 is a high-severity vulnerability in ethyca fides, published on 8 Sep 2025. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

Fides is an open-source privacy engineering platform. Prior to version 2.69.1, the OAuth client creation and update endpoints of the Fides Webserver API do not properly authorize scope assignment. This allows highly privileged users with `client:create` or `client:update` permissions to escalate their privileges to owner-level. Version 2.69.1 fixes the issue. No known workarounds are available.

Weakness: CWE-862 (Missing Authorization)

## Which versions are affected by CVE-2025-57817?

3 open source packages ship an affected version, including ethyca-fides. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `ethyca-fides` | PyPI | All versions | 2.69.1 |
| `ethyca-fides` | PyPI | All versions | 2.69.1 |
| `ethyca-fides` | PyPI | All versions | 2.69.1 |

Products: Ethyca Fides.

## How do I fix CVE-2025-57817?

Upgrade ethyca-fides to 2.69.1 or later.

## Is CVE-2025-57817 being exploited?

There is no known exploitation of CVE-2025-57817 in the wild and no public exploit code.

## Other vulnerabilities in ethyca fides

- [CVE-2024-45053](https://insights.sbomify.com/CVE-2024-45053/): Remote Code Execution Vulnerability via SSTI in Fides Webserver Jinja Email Templating Engine (critical 9.1)
- [CVE-2023-41319](https://insights.sbomify.com/CVE-2023-41319/): Remote Code Execution in Custom Integration Upload in Fides (high 8.8)
- [CVE-2023-48224](https://insights.sbomify.com/CVE-2023-48224/): Cryptographically Weak Generation of One-Time Codes for Identity Verification in ethyca-fides (high 8.2)
- [CVE-2023-46124](https://insights.sbomify.com/CVE-2023-46124/): Server-Side Request Forgery Vulnerability in Custom Integration Upload (high 8.2)
- [CVE-2023-36827](https://insights.sbomify.com/CVE-2023-36827/): Fides vulnerable to Path Traversal in Webserver API (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-57817 and fix it if it is affected.

What it is: CVE-2025-57817 is a high-severity vulnerability in ethyca fides, published on 8 Sep 2025. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-57817 in the wild and no public exploit code.

Affected packages and fixed versions:
- ethyca-fides (PyPI): affected all versions; fixed in 2.69.1
- ethyca-fides (PyPI): affected all versions; fixed in 2.69.1
- ethyca-fides (PyPI): affected all versions; fixed in 2.69.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-57817/ (Markdown: https://insights.sbomify.com/CVE-2025-57817/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-57817
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-57817
- OSV: https://osv.dev/vulnerability/CVE-2025-57817

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-57817/
Summaries are generated and may contain mistakes; the official description above is the record.
