# CVE-2025-57820: Svelte devalue vulnerable to prototype pollution

> Attackers can pollute object prototypes via crafted strings in devalue.parse, potentially leading to code execution or privilege escalation in Svelte applications.

- **Severity:** High 7.9 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:N/SC:H/SI:H/SA:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 26 Aug 2025
- **Updated:** 27 Aug 2025
- **Also known as:** CLSA-2026-1774398079, GHSA-vj54-72f3-p5jv, ROOT-APP-NPM-CVE-2025-57820

## What is CVE-2025-57820?

CVE-2025-57820 is a high-severity vulnerability in sveltejs devalue, published on 26 Aug 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Svelte devalue is a utility library. Prior to version 5.3.2, a string passed to devalue.parse could represent an object with a __proto__ property and devalue.parse does not check that an index is numeric. This could result in assigning prototypes to objects and properties, leading to prototype pollution. This issue has been fixed in version 5.3.2

Weakness: CWE-1321 (Improperly Controlled Modification of Object Prototype Attributes)

## Which versions are affected by CVE-2025-57820?

2 open source packages ship an affected version, including devalue.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `devalue` | npm | All versions | 5.3.2 |
| `devalue` | npm | All versions | 5.3.2 |

## How do I fix CVE-2025-57820?

Upgrade devalue to 5.3.2 or later.

## Is CVE-2025-57820 being exploited?

There is no known exploitation of CVE-2025-57820 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-57820 and fix it if it is affected.

What it is: CVE-2025-57820 is a high-severity vulnerability in sveltejs devalue, published on 26 Aug 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-57820 in the wild and no public exploit code.

Affected packages and fixed versions:
- devalue (npm): affected all versions; fixed in 5.3.2
- devalue (npm): affected all versions; fixed in 5.3.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-57820/ (Markdown: https://insights.sbomify.com/CVE-2025-57820/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-57820
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-57820
- OSV: https://osv.dev/vulnerability/CVE-2025-57820

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-57820/
Summaries are generated and may contain mistakes; the official description above is the record.
