{"answers":{"affected":"2 open source packages ship an affected version, including google_sign_in.","exploited":"There is no known exploitation of CVE-2025-57821 in the wild and no public exploit code.","fix":"Upgrade google_sign_in to 1.3.0 or later.","what":"CVE-2025-57821 is a medium-severity vulnerability in basecamp google_sign_in, published on 27 Aug 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2025-57821 and fix it if it is affected.\n\nWhat it is: CVE-2025-57821 is a medium-severity vulnerability in basecamp google_sign_in, published on 27 Aug 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2025-57821 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- google_sign_in (RubyGems): affected all versions; fixed in 1.3.0\n- google_sign_in (RubyGems): affected all versions; fixed in 1.3.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-57821/ (Markdown: https://insights.sbomify.com/CVE-2025-57821/index.md)","id":"CVE-2025-57821","markdown":"https://insights.sbomify.com/CVE-2025-57821/index.md","name":"CVE-2025-57821","record":{"aliases":["GHSA-7pwc-wh6m-44q3"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":true,"product_category":"Rails Google Sign-In","requires_auth":"none","summary":"Attackers can redirect users to malicious sites via malformed URLs, potentially enabling session cookie injection attacks in Rails applications.","user_interaction":"required","vuln_class":"open_redirect"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":4.2,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-601","name":"URL Redirection to Untrusted Site"}],"description":"Basecamp's Google Sign-In adds Google sign-in to Rails applications. Prior to version 1.3.0, it is possible to craft a malformed URL that passes the \"same origin\" check, resulting in the user being redirected to another origin. Rails applications configured to store the flash information in a session cookie may be vulnerable, if this can be chained with an attack that allows injection of arbitrary data into the session cookie. This issue has been patched in version 1.3.0. If upgrading is not possible at this time, a way to mitigate the chained attack can be done by explicitly setting SameSite=Lax or SameSite=Strict on the application session cookie.","ecosystems":["RubyGems"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Basecamp's Google Sign-In for Rails allowed redirects to a malformed URL","id":"CVE-2025-57821","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"RubyGems","product":null,"products":[],"type":"open_redirect","year":"2025"},"n_packages":2,"n_references":4,"next":{"headline":"Next.js Improper Middleware Redirect Handling Leads to SSRF","id":"CVE-2025-57822"},"packages":[{"ecosystem":"RubyGems","fixed":["1.3.0"],"introduced":["0"],"last_affected":[],"package":"google_sign_in","purl":null,"source":"GHSA-7pwc-wh6m-44q3"},{"ecosystem":"RubyGems","fixed":["1.3.0"],"introduced":["0"],"last_affected":[],"package":"google_sign_in","purl":"pkg:gem/google_sign_in","source":"GHSA-7pwc-wh6m-44q3"}],"prev":{"headline":"Svelte devalue vulnerable to prototype pollution","id":"CVE-2025-57820"},"products":["google_sign_in"],"published":"2025-08-27","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-08-27","vendors":["basecamp"]},"summary":"Attackers can redirect users to malicious sites via malformed URLs, potentially enabling session cookie injection attacks in Rails applications.","url":"https://insights.sbomify.com/CVE-2025-57821/"}